Bug #57361 Cannot start/stop Mysql server from System Preferences Panel in Mac
Submitted: 11 Oct 2010 8:49 Modified: 11 Oct 2010 9:48
Reporter: Jay Xu Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server Severity:S2 (Serious)
Version:5.5.6 rc OS:Mac OS X (10.6.4)
Assigned to: CPU Architecture:Any

[11 Oct 2010 8:49] Jay Xu
Description:
After install mysql server and preference panel from DMG file on mac, the server cannot be started from System Preferences Panel.

The follow messages can be fond in system console:

10-10-11 下午04:33:40	[0x0-0xec0ec].com.apple.systempreferences[9623]	/usr/local/mysql/support-files/mysql.server: line 256: my_print_defaults: command not found

How to repeat:
1. Download "mysql-5.5.6-rc-osx10.6-x86_64.dmg" from dev.mysql.com
2. Install "mysql-5.5.6-rc-osx10.6-x86_64.pkg" and "MySQL.prefPane" from the DMG file
3. Open System Preferences Panel, click "MySQL"
4. Status of Mysql server is "stopped" now, click "Start MySQL Server"
5. After a while, nothing happened, status of Mysql server is still "stopped"
[11 Oct 2010 9:48] Sveta Smirnova
Please do not submit the same bug more than once. An existing bug report already describes this very problem. Even if you feel that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments to the original bug instead.

Thank you for your interest in MySQL.

Duplicate of bug #51264