Bug #57157 Closing MySQL Workbench - Memory Error
Submitted: 1 Oct 2010 2:35 Modified: 1 Oct 2010 17:48
Reporter: Mike Cross Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2 CE OS:Microsoft Windows (XP)
Assigned to: CPU Architecture:Any

[1 Oct 2010 2:35] Mike Cross
Description:
Exception = System.AccessViolationException
Message = Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
FullText = System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
   at boost.checked_delete<class Db_sql_editor>(Db_sql_editor* x)
   at boost.detail.sp_counted_impl_p<Db_sql_editor>.dispose(sp_counted_impl_p<Db_sql_editor>* )
   at boost.detail.sp_counted_base.release(sp_counted_base* )
   at boost.detail.shared_count.{dtor}(shared_count* )
   at boost.shared_ptr<Db_sql_editor>.{dtor}(shared_ptr<Db_sql_editor>* )
   at boost.shared_ptr<Db_sql_editor>.__delDtor(shared_ptr<Db_sql_editor>* , UInt32 )
   at MySQL.Grt.ManagedRef<Db_sql_editor>.reset()
   at MySQL.Grt.ManagedRef<Db_sql_editor>.~ManagedRef<Db_sql_editor>()
   at MySQL.Grt.ManagedRef<Db_sql_editor>.Dispose(Boolean )
   at MySQL.Grt.ManagedRef<Db_sql_editor>.Dispose()
   at MySQL.GUI.Workbench.Db_sql_editor.~Db_sql_editor()
   at MySQL.GUI.Workbench.Db_sql_editor.Dispose(Boolean )
   at MySQL.Grt.UIForm.Dispose()
   at MySQL.GUI.Workbench.DbSqlEditor.Destroy()
   at MySQL.GUI.Workbench.DbSqlEditor.Dispose(Boolean disposing)
   at System.ComponentModel.Component.Dispose()
   at System.Windows.Forms.Form.WmClose(Message& m)
   at System.Windows.Forms.Form.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
Also running MySQL Command Line Client in another window.
[1 Oct 2010 17:48] Alfredo Kojima
Im marking this as a duplicate of bug #56963 
If this bug persists in 5.2.29, please reopen it.