Bug #56874 Cannot open connection unless ssh logon is working
Submitted: 20 Sep 2010 15:38 Modified: 12 Oct 2010 13:45
Reporter: John Haney Email Updates:
Status: Closed Impact on me:
Category:MySQL Workbench: Administration Severity:S1 (Critical)
Version:5.2.28 OS:Windows
Assigned to: Maksym Yehorov CPU Architecture:Any

[20 Sep 2010 15:38] John Haney
It appears you cannot connect to a database for administration unless ssh is working.

If you create a new connection and choose not to logon through ssh you get prompted asking to connect to db only but the admin fails to start.

If you use an existing connection and don't use correct password the admin asks to connect to db only but fails to start.

If you use an existing connection and uncheck the ssh admin before trying to start you get the following exception: Exception: Unsupported administration target type: ('windows','linux','local')

I have not tried a completely new install as that really should not be an option for existing installs.

How to repeat:
Try any of the above on a normal install over 5.2.27.
[21 Sep 2010 6:01] kai zhang
got same problem. The error popped out and really freaked me out
[22 Sep 2010 2:12] Tak Chi Lin
Yes, same here, can't do any db backup.
[22 Sep 2010 3:58] Yinyin Liao
upgrade from 5.2.25 and have same issue here, but on OS X.
[22 Sep 2010 23:00] Maleika Edwards
I had the same issue.  I simple restarted my machine and then it worked correctly.
[23 Sep 2010 13:12] John Haney
I tried a machine restart and the error still exists.
[23 Sep 2010 14:08] Tiago de Assis Gonçalves
got same problem.

Exception: Unsupported administration target type: ('windows', 'unknown', 'local')

The connection only works in localhost.

In remote servers the error ocurred in the following versions: 5.1.45-community, 5.0.67-community-nt, 5.1.34-community
[28 Sep 2010 17:28] David Frost
I had the same problem, and discovered that I was using a MySQLWorkbench connection that was connecting as a MySQL database user that did not have sufficient privileges within the database. The connection was fine when used for SQL development but wouldn't work for administration. Once I setup a new connection that connected as user "mysql" it worked fine.

The bug still needs fixing however, as the error message displayed doesn't help you diagnose the problem.
[28 Sep 2010 17:33] David Frost
Sorry...slight correction to my previous comment: the user profile connected as MySQL user "root" rather than "mysql". My database is a development database with very little security at the moment. You may need to find a user other than root that has the necessary administrative permissions.
[28 Sep 2010 19:19] [ name withheld ]
I got this error.  I just updated from Workbench 5.2.26 to 5.2.28 to get rid of the Invalid Node Index error to get the Querying part working and then I got this error instead so the Administration isn't working (Querying part hasn't given me Invalid Node error anymore though :)  ).  I will try reboot and will have to install SSH.
[28 Sep 2010 20:22] John Haney
Just to be clear - it's not a mysql user issue. If I connect with ssh working all is good. It's only when ssh is not working.

Not sure if this is related but it'll crash hard I see this error as well:

Faulting application mysqlworkbench.exe, version, stamp 4c94206f, faulting module libmysql.dll, version, stamp 4b8c387c, debug? 0, fault address 0x0003794c.
[30 Sep 2010 16:42] Sergio Torres
Same problem here, this needs to get fixed pls!
[1 Oct 2010 14:33] Thomas Johnson
I cannot connect to any remote servers at all.  Don't have SSH installed, but I used to use the old MySQL Administror to view permissions, schemes and connections.  All of whcih only required a SQL connection and now it will not connect even with root.
[1 Oct 2010 14:45] Ignacio Santolin
Same error trying to backup remote MySQL server
[2 Oct 2010 19:10] David Boucher
I have the same issue, I can't run remote administration either in SSH or Non SSH Connection
[4 Oct 2010 15:49] sergio tagliapietra
Same exact error here..
[4 Oct 2010 22:12] Denny Driggs
Same here.  Please fix asap.
[6 Oct 2010 11:03] Georgi Sotirov
I really cannot understand how such an obvious problem was omitted by QA. Please, provide a new release to fix this as soon as possible as it's blocking for most of us. I do not want to use SSH management on all of my instances.
[6 Oct 2010 13:34] Tony Walker
Same problem here - any remote connection without ssh causes this issue. (Note: Using user root makes no difference - the problem exists as described above)
[6 Oct 2010 13:40] Tony Walker
Just one last thing - a bug this huge and you don't even offer the possibility of downloading the previous GA versions without this issue (26? 27?) on your website as an interim measure? A triage option would be helpful - please provide the link on this bug report. 

You should also consider pulling 5.2.28 completely until this is resolved. The fix for the Invalid Node Index (trivial bug with remote admin) replaced with a critical bug that prevents all remote admin without ssh - I would roll back if this was my application.

[6 Oct 2010 15:33] Stan Dragnev
I'm having this issue as well.

I'm using the old Admin in mysql gui tools - this works fine.
[6 Oct 2010 20:17] Garen Parham
Just ran into this issue after upgrading from 5.2.27.  Had to uninstall 5.2.28 and reinstall 5.2.27.

Most frustrating is that the error dialog which says:
Exception: Unsupported administration target type:

Is underneath the transparent splash screen ("Starting MySQL WorkBench ...") which makes it impossible to even click the "OK" button on the error dialog. UGH.

Tried to take a screenshot of it, but the splash screen doesn't show up with ALT+PRTSCRN (!!) UGH++;
[6 Oct 2010 21:04] Marcus Borelli Ribeiro
At first I also could not access my database but when I passed by SSH to access everything works. I think that is essential to use SSH.
[6 Oct 2010 21:23] Georgi Sotirov
> I think that is essential to use SSH.
Yep, but it shouldn't be. What if I do not have SSH enabled on the host? It was not required before, so I do not see why it should be required now.
[7 Oct 2010 17:08] Johannes Taxacher
fix confirmed in repository
[8 Oct 2010 15:09] MySQL Verification Team
Bug: http://bugs.mysql.com/bug.php?id=57236 marked as duplicate of this one.
[12 Oct 2010 13:45] Tony Bedford
An entry has been added to the 5.2.29 changelog:

It was only possible to connect to a MySQL server for administration using an SSH connection.