Bug #56873 Method not found
Submitted: 20 Sep 2010 15:06 Modified: 5 Dec 2010 17:20
Reporter: John Haney Email Updates:
Status: No Feedback Impact on me:
Category:MySQL Workbench Severity:S1 (Critical)
Version:5.2.28 OS:Windows
Assigned to: CPU Architecture:Any
Tags: regression

[20 Sep 2010 15:06] John Haney
The following error prevents the administrator from connecting to a datasource when trying to start the SQL editor:

Method not found: 'System.Collections.Generic.List'1<MySQL.Grt.NodeId>MySQL.Utilities.Gridview.SelectedNodes()'

How to repeat:
Not sure but all I did was a normal install over the previous 5.2.27 install which was working just fine.

Suggested fix:
Not sure.
[23 Sep 2010 11:36] Johannes Taxacher
Hi John,
can you explain in more detail? How do you reproduce the problem and with what profiles are they appearing (local server, remote server, any)?
thanks in advance
[23 Sep 2010 13:20] John Haney
Not sure there is much more detail I can provide. I simply try to open any connection with the sql editor and it fails with the same error. It doesn't matter if it is a remote connection or localhost connection. I tried adding a new connection and it fails with same error as an existing connection.
[26 Sep 2010 20:50] Valeriy Kravchuk
Please, send the results of Help > System Info menu item.
[27 Sep 2010 23:44] John Haney
MySQL Workbench CE for Windows version 5.2.28

Data Directory: C:\Program Files\MySQL\MySQL Workbench 5.2 CE

Cairo Version: 1.8.8

Rendering Mode: OpenGL is available on this system, so OpenGL is used for rendering.

OpenGL Driver Version: 2.1.7415 Release

OS: Microsoft Windows XP Professional Service Pack 3 (build 2600)

CPU: 2x Intel(R) Core(TM)2 Duo CPU     E8400  @ 3.00GHz, 3.0 GiB RAM

Video adapter info:

Adapter type: ATI Radeon HD 2400 Pro  

Chip Type: ATI Radeon Graphics Processor (0x94C1)

BIOS String: 113-B27602-113

Video Memory: 262144 KB

Current user language: English (United States)
[28 Oct 2010 22:31] Alfredo Kojima
Does this error also happen with 5.2.29?
[28 Oct 2010 22:31] Alfredo Kojima
"Not sure but all I did was a normal install over the previous 5.2.27 install which was
working just fine."

How did you do the install? From the zip file or msi?
[28 Oct 2010 22:40] John Haney
Installed with the MSI. Not sure if it still happens in 5.0.29 as I can't keep that version running. Keeps crashing with following error:

Faulting application mysqlworkbench.exe, version, stamp 4cb2cc03, faulting module libmysql.dll, version, stamp 4b8c387c, debug? 0, fault address 0x0003794c.

I reverted back to 5.0.26 for now.

[5 Nov 2010 17:20] Johannes Taxacher
Hello John,
could you try the zip package of 5.2.29, or completely remove the previous version (uninstall and, to be sure, wipe the install dir, which is by default "Program Files/MySQL Workbench CE") before installing 5.2.29 from msi?
[6 Dec 2010 0:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".