Bug #5678 MyODBC appears to install, but does not show up on driver list
Submitted: 21 Sep 2004 0:37 Modified: 25 Apr 2005 23:04
Reporter: Jett Hanna Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S1 (Critical)
Version:3.51.9 OS:Microsoft Windows (Windows XP SP2)
Assigned to: Bugs System CPU Architecture:Any

[21 Sep 2004 0:37] Jett Hanna
Description:
MyODBC appears to install normally, shows up in programs list.  However, when you try to create a DSN, it does not show up in driver list as a choice.  It doesn't show up on the driver tab, either.  I tried on another XP machine without SP2, and it worked fine.

How to repeat:
Try to install on an XP2 machine.

Suggested fix:
No clue.
[5 Oct 2004 15:22] George Chacko
"However, when you try to create a DSN, it does not show up in driver list as a choice." Same problem here. I'm running XP SP2 as well. George Chacko
[17 Oct 2004 1:48] Dave Schmall
Same problem with XP SP2 - driver appears to install correctly but doesn't show up in the ODBC driver list.  Uninstalled and reinstalled as well - still doesn't appear.
[20 Oct 2004 17:51] George Chacko
I also tried some of the solutions out on the net including 

a)  including installing in safe mode 

b) importing the following .reg file

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\MySQL ODBC 3.51 Driver]
"UsageCount"=dword:0000000c
"Driver"="C:\\WINNT\\System32\\myodbc3.dll"
"Setup"="C:\\WINNT\\System32\\myodbc3.dll"
"APILevel"="2"
"ConnectFunctions"="YYN"
"DriverODBCVer"="03.51"
"FileUsage"="0"
"FileExtns"="*.txt"
"SQLLevel"="1"
"CPTimeout"="60"
"DSNHelpFile"="C:\\WINNT\\help\\my3dsn.hlp"

c) exporting the ODBC director from the registry, deleting it, and re-importing it (separated by reboots). 

Still doesn't work for me. GC
[2 Nov 2004 20:43] Harun Eren
The following steps can be use as background for the bug:
 --------------------------------------------------------
 1.Call "regedit" programm under WindowsXP
 2.The registry structur [HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\ODBC Drivers]
   must export to the .reg file.
 3.After then deleted the structur [HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\ODBC Drivers]
   in the registry.
 4.Edit the exported .reg file, with deleted following line  >>> @="" <<<,
 5.Save the .reg file
 6.Import the .reg file with the registry programm or call the .reg file to be save the Driverskey

 After these steps the drivers are listed correctly in the Microsoft Driver Manager.
[2 Nov 2004 20:48] Harun Eren
Thank you for your bug report. This issue has been addressed in the
documentation. The updated documentation will appear on our website
shortly, and will be included in the next release of the relevant
product(s).
[15 Sep 2005 23:07] Erik Alfkin
This only happens when I install it on a computer that authenticates against a domain
[11 Oct 2005 12:46] Lou St. Amant
I am having the same problem.  Running XP Pro, SP2, 5.1.2600 build 2600.  Have installed several times without any sign of problems; yet, the driver just isn't there. Any suggestions that don't involve reg.edit?
[29 Jan 2009 16:59] Lucas Oliveira
I am having this problem on Windows Vista Machine and Windowsw XP SP3 too.
Someone solved the problem? I've tried some solution that i've found on google and don't work.
Thanks
[29 Jan 2009 20:59] Erik Alfkin
In my case, it had something to do with FileMaker Pro 7 (it was the only consistent commonality). I uninstalled FileMaker and the ODBC driver showed up. I reinstalled FileMaker and the driver has not disappeared since. I don't know why this worked.