Bug #56730 Connector/Net 6.3.4 needs .Net 4 to install, fails with unhelpful error msg
Submitted: 11 Sep 2010 14:33 Modified: 13 Sep 2010 6:34
Reporter: Matt Richards Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / NET Severity:S2 (Serious)
Version:6.3.4 OS:Microsoft Windows (7)
Assigned to: CPU Architecture:Any
Tags: Connector/Net, installation, windows 7

[11 Sep 2010 14:33] Matt Richards
Description:
Connector/Net 6.3.4 install fails with "installation ended prematurely" message if .NET 4 is not installed on the target system.  Installing .NET 4 fixes it, but the only way to learn what the error is is to go through the "enabling verbose logging for .msis" process.

How to repeat:
Install Connector/Net 6.3.4 on a machine that does not have .NET 4 installed.

Suggested fix:
Best would be if the installer did not require .NET 4, the most recent version, which not everyone is going to have.  Also the installer should report exactly what the problem was, and for this particular problem, should check for the presence of .NET 4 at runtime and report if it is not available.  (A similar issue with this installer not reporting its errors in a helpful manner was logged as a bug on version 5, and marked fixed, but evidently that fix did not fix this sort of thing).
[13 Sep 2010 6:34] Tonci Grgin
Please do not submit the same bug more than once. An existing bug report already describes this very problem. Even if you feel that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments to the original bug instead.

Thank you for your interest in MySQL.

Explanation: Hi Matt. IMO, this is a duplicate of problem reported in Bug#56580.