Bug #56600 apache segmentation fault (11) inserting columns with more than 10.000 caracters
Submitted: 6 Sep 2010 17:41 Modified: 6 Sep 2010 20:30
Reporter: Javier Vega Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: General Severity:S1 (Critical)
Version:5.0.77 OS:Linux (CentOS VPS OpenVZ)
Assigned to: CPU Architecture:Any
Tags: large queries, segmentation fault

[6 Sep 2010 17:41] Javier Vega
Description:
Every time I try to insert a record where a column is larger than 10.000 caracters, apache server crashes with a segmentation fault (11). No core dump file is generated.

If number of characters of the column is less than 10.000 it works OK.

The large column type is TEXT but a tried also with VARCHAR, BLOB, etc and occurs the same.

I am running the query with PHP:
PHP 5.1.6 (cli) (built: Mar 31 2010 02:39:17)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies
    with Zend Optimizer v3.3.3, Copyright (c) 1998-2007, by Zend Technologies

How to repeat:
Executing from PHP a query like this:

INSERT INTO TABLE_NAME (
        ID,
        CLIENTE,
        PROYECTO,
        TITULO,
        PLANIFICACION,
        CATEGORIA,
        DESCRIPCION,
        PLANTILLASMS,
        PLANTILLAEMAIL,
        DESTINATARIOS,
        ASUNTO
        ) VALUES (
        0,
        1,
        6,
        'PRUEBA',
        0,
        'Operador',
        'any string larger than 10.000 caracters ....',
        0,
        1,
        'MAIL@SERVER.COM',
        'Asunto'
        )"

Suggested fix:
I don't know
[6 Sep 2010 17:53] Miguel Solorzano
Thank you for the bug report. Why do you think it is MySQL Server bug and not PHP/Apache one?. Thanks in advance.
[6 Sep 2010 20:29] Javier Vega
After your question, I have just test it with mysql and it works. So it is sure it is a PHP/Apache bug.

Sorry for the inconvenience.
[6 Sep 2010 20:30] Javier Vega
It is not a bug of MYSQL