Bug #56589 EER Diagram not showing up in one of the dual screens
Submitted: 6 Sep 2010 11:40 Modified: 9 Oct 2010 16:01
Reporter: Jing Tang Email Updates:
Status: No Feedback Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S3 (Non-critical)
Version:5.2.27CE OS:Microsoft Windows (XP SP3)
Assigned to: CPU Architecture:Any
Tags: EER diagram dual screen

[6 Sep 2010 11:40] Jing Tang
Description:
When creating/opening EER diagrams, the diagram will only show up when MySQL workbench is on the second working screen of the 2 screens.

How to repeat:
Have dual screen set up; open MySQL workbench in the first screen; create or open an EER diagram.
[6 Sep 2010 12:17] Miguel Solorzano
Thank you for the bug report. Sorry I don't understand very well are you able to provide a screen-shot which illustrate the issue?. Thanks in advance.
[6 Sep 2010 13:16] Jing Tang
main view is blank when workbench running on the 1st screen

Attachment: blank.JPG (image/jpeg, text), 233.67 KiB.

[6 Sep 2010 13:17] Jing Tang
main diagram view is normal when workbench running on the 2nd screen

Attachment: notblank.JPG (image/jpeg, text), 319.38 KiB.

[6 Sep 2010 22:13] Miguel Solorzano
dual monitor

Attachment: dual_display.png (image/png, text), 342.08 KiB.

[6 Sep 2010 22:18] Miguel Solorzano
Thank you for the feedback. I couldn't repeat (see prior picture attached) on dual monitor running Vista 64-bit. Please provide the output of Help->System Info. Thanks in advance.
[7 Sep 2010 15:10] Jing Tang
MySQL Workbench CE for Windows version 5.2.27

Data Directory: C:\Program Files\MySQL\MySQL Workbench 5.2 CE

Cairo Version: 1.8.8

Rendering Mode: OpenGL is available on this system, so OpenGL is used for rendering.

OpenGL Driver Version: 2.0.6956 WinXP Release

OS: Microsoft Windows XP Professional Service Pack 3 (build 2600)

CPU: 2x Intel(R) Pentium(R) 4 CPU 2.80GHz, 3.6 GiB RAM

Video adapter info:

Adapter type: RADEON Radeon X300/X550/X1050 Series

Chip Type: ATI Radeon Graphics Processor (0x5B60)

BIOS String: 113-A62801-106

Video Memory: 131072 KB
[9 Sep 2010 16:01] Miguel Solorzano
I have ATI video card too, I installed the Catalyst suite to setup my environment.
[4 Oct 2010 18:10] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/119907
[9 Oct 2010 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".