Bug #56356 Grid text overlapping text after vertical scrolling
Submitted: 30 Aug 2010 8:05 Modified: 4 May 2011 13:35
Reporter: pedro oriani Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.26 CE, 5.2.27, 5.2.28, 5.2.29 OS:Microsoft Windows
Assigned to: Mike Lischke CPU Architecture:Any

[30 Aug 2010 8:05] pedro oriani
Description:
If datagrid is partially off of screen, vertical scrolling generates text overlapping, so the content of cells is unreadable.
The same problem is also with horizontal scrolling.
Note: vertical problem is show when the window is bottom side off-screen, horizontal one when is left/right side off

How to repeat:
Execute a query with enough rows to activate vertical scrolling, then drag down the windows partially off of the screen.
Now scroll down the grid (mouse scroller or arrow down).
I get text overlapping (Win7x64)
[30 Aug 2010 8:43] Valeriy Kravchuk
Please, send the results of Help > System Info.
[30 Aug 2010 9:00] pedro oriani
MySQL Workbench CE for Windows version 5.2.26
Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
Rendering Mode: OpenGL is available on this system, so OpenGL is used for rendering.
OpenGL Driver Version: 3.3.10151 Compatibility Profile Context
OS: Microsoft Windows 7  (build 7600), 64-bit
CPU: 8x Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz, 6.0 GiB RAM
Video adapter info:
Adapter type: ATI Radeon HD 4800 Series         
Chip Type: ATI display adapter (0x9442)
BIOS String: 11X-2E104DSA-QIM
Video Memory: 524288 KB
[30 Aug 2010 13:09] MySQL Verification Team
It is possible to attach a screen-shot which shows that issue?. Thanks in advance.
[30 Aug 2010 13:40] pedro oriani
overlapping problem

Attachment: wb_problem.jpg (image/jpeg, text), 68.92 KiB.

[1 Sep 2010 8:15] Valeriy Kravchuk
Please, check with a newer version, 5.2.27, and inform about the results.
[1 Sep 2010 17:36] pedro oriani
just upgraded... no changes...
[20 Sep 2010 7:13] pedro oriani
No Changes with new release
[9 Oct 2010 14:01] Valeriy Kravchuk
Please, check if the same problem happens when you start Workbench from the command line with -swrendering option.
[11 Oct 2010 7:55] pedro oriani
No changes, still overlapping.

this is sysinfo:

OpenGL is available on this system, but GDI was requested. Using GDI for rendering.

bye
[13 Oct 2010 15:50] pedro oriani
Same with 5.2.29
[18 Nov 2010 18:53] Alfredo Kojima
I can repeat this in Win7 inside vmware.
[4 May 2011 13:35] Mike Lischke
I'm afraid we cannot fix this. The problem is caused by the underlying .NET control we use (DataGridView), whose behavior we cannot change.