Bug #56197 In Setup Wizard license agreement is unreadable -- font size too small
Submitted: 23 Aug 2010 20:17 Modified: 1 Nov 2010 10:44
Reporter: Elena Stepanova Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Server: Installing Severity:S3 (Non-critical)
Version:5.5, 5.6 OS:Microsoft Windows
Assigned to: Staale Deraas CPU Architecture:Any

[23 Aug 2010 20:17] Elena Stepanova
Description:
In the new installer the 2nd screen is 'End-User License Agreement'. The license text in the area is unreadable, as the font is too small. 
Screenshot is attached, compare the license text to the surrounding lines, e.g. 'I accept...' or 'Please read...'.

How to repeat:
- start MySQL server installer;
- proceed to the 2nd screen;
- see the license agreement text.

Suggested fix:
Increase the font size if possible.
[3 Sep 2010 11:18] Elena Stepanova
License agreement screenshot

Attachment: license_560.jpg (image/jpeg, text), 43.80 KiB.

[30 Sep 2010 12:40] Daniel Fischer
This is working as intended, I picked this size intentionally. It's easily readable for me on your screenshot, and I have notoriously bad eyesight.

The reasons are technical, though. The installer uses the COPYING document included in the source. When this is the GPL, it's a document written to be displayed in a window that is 80 columns wide, and using a monospace font. WiX will re-flow the text if it is too wide, you can already see this happen in the screenshot. If I just increase the font size, it will make the document look plain ridiculous because every other line will be half length.

The installer has support for formatted text in RTF format and it is written in a way that prefers an RTF document if one is there. If necessary, I can re-format the GPL with Wordpad, using a larger font size, and just plug it in as a replacement. But this would mean that we have to maintain two different sets of licenses for Windows and !Windows.

Before I do that, I would like some feedback if this is really so unreadable that it warrants the overhead of maintaing two different sets of licenses.
[30 Oct 2010 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".