Bug #56151 When attempting connect to remote server to administer throws a conn fault
Submitted: 20 Aug 2010 16:15 Modified: 10 Jun 2011 18:48
Reporter: Pat Sinclair Email Updates:
Status: No Feedback Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S1 (Critical)
Version:5.2.29 ce 6756 OS:Windows (Vista SP1)
Assigned to: Alfredo Kojima CPU Architecture:Any
Tags: regression

[20 Aug 2010 16:15] Pat Sinclair
Description:
when attempting to manage server (remote machine) a fault is thrown:
"Lost connection to MySql server at 'reading initial communication packet', system error:0  Connection paramaters might be incorrect or the server might be down.  Some functionality will not be available."
The server is running with out any errors.
I am able to open the database, run queries, alter tables etc using the same connection..

Mysql administrator 1.2.17 still works fine.

How to repeat:
This is extremely repeatable(every time). 
double click on the connection in the server administration area.
Click on manage /dump really any options and the error happens.

Suggested fix:
?????
[21 Aug 2010 1:35] MySQL Verification Team
Thank you for the bug report. What type of connection method are you using? Which OS and server version are you connecting?. Thanks in advance.
[24 Aug 2010 18:17] Pat Sinclair
The OS version of the server is windows 2003 server standard.  MySql 5.1.32-community.

Thanks for the research in advance.
[24 Aug 2010 18:19] Pat Sinclair
Sorry forgot to add the connection method TCP/IP standard.
[24 Aug 2010 19:11] Sveta Smirnova
Thank you for the feedback.

Verified as described.

Local OS: Windows Vista
Remote OS: MacOS X Tiger
[25 Aug 2010 12:13] Pat Sinclair
The remote machine was not Tiger OS, are you saying that it happens the same there?
[3 Sep 2010 3:17] Pat Sinclair
This is still the case in 5.2.27 CE!  Does anyone have any ideas on how to fix this?
[7 Sep 2010 21:08] Frank Mueller
I have the same Error here:

MySQL Workbench 5.2.27 (Build 6485) running on Windows 7 (32 Bit)

Target MySQL
5.1.47 Advanced running on Solaris 10

On connection attemt via Server Administration i got sometimes Error that the ssh credentials are not ok (they are double verified via putty, and stored in vault) or sometimes that the connection to the mysql canĀ“t be established. If I hit cancel sometimes the server administrations shows up and everything is working fine.

As sayed.. connectionto the Server via putty works well. Using MySQL Administrator works well, too.
[29 Sep 2010 21:10] Alfredo Kojima
I was able to repeat this from a server that takes long to connect to MySQL. It is because of a timeout.
I've now increased the timeout.

As a workaround to use with current version of WB, you can try the following:

- open the connections.xml file from WB's data dir at C:\Users\<YOU>\AppData\Roaming\MySQL\Workbench with some text editor
- locate the connection you're having trouble with and go to the line containing it's hostName, for example:

        <value type="string" key="hostName">10.128.19.53</value>

- add a line like this right below it:
        <value type="int" key="OPT_READ_TIMEOUT">30</value>

- make a backup copy of the original file, save and start WB

I can't guarantee this will work, but if it does, please report, as that would mean the fix indeed works for you.
[30 Sep 2010 13:53] Pat Sinclair
This still continues!

I updated to the latest release...

I tried your recommendation Alfredo, I even increased the time to 60 and still no go.

The error that I receive now is "Could not connect to ..."
Lost connection to Mysqls server at 'reading initial communication packet', system error: 0 You may continue anyway, but some functionality witll be unavailable.

If I press continue I get Error Starting WorkBench Administrator
"Exception: Unsupported administration target type:("windows","unknown","local")

Please let me know what and or if there is anything I can do to aid in discovering the source of this problem.

Regards,
Pat
[18 Oct 2010 2:35] Pat Sinclair
Screen shot of connection failure

Attachment: screen dump.jpg (image/pjpeg, text), 12.13 KiB.

[18 Oct 2010 2:36] Pat Sinclair
This still continues, changing the timeout never worked.  Please see attached a screen dump of the error dialog, it is tweaking the ip address.
[26 Oct 2010 22:30] Alfredo Kojima
Sveta: please provide more details about how to repeat this.

Pat: pls send a sshot of the connection details for what you're trying to use (from the Connections editor)
[27 Oct 2010 19:49] Pat Sinclair
See attached the settings that I am attempting and also the error when attempting the connection.
[27 Oct 2010 19:53] Pat Sinclair
Connection Fail

Attachment: connectionfail.jpg (image/pjpeg, text), 52.23 KiB.

[27 Oct 2010 19:54] Pat Sinclair
Connection Setup

Attachment: connectionsetup.jpg (image/pjpeg, text), 52.13 KiB.

[1 Nov 2010 22:15] Sveta Smirnova
Alfredo,

it works exactly like in the initial description.
[16 Nov 2010 1:14] Alfredo Kojima
The error I see in the screenshots is Access Denied, which implies an invalid user and/or password was supplied when connecting.
[17 Nov 2010 13:16] Niels Fahse
I have the same problem with WB 5.2.29 CE Rev. 6756 running on Windows 7 64 bit.

I created a connection with PW stored in vault.
With this connection I can do queries, alter tables etc.

Creating a server instance using this same connection is no problem. During creation WB connects to the server and shows server version and OS of the server. Also the ssh-login is no problem.

But when I try to start administration by double-clicking the instance an error occurs:
"Lost connection to MySQL server at 'reading initial communication packet', system error: 0 
You may continue anyway, but some functionality will be unavailable"

If I continue the administration tab is shown but administration is not possible (except shutting down MySQL via ssh). 

This error only happens with ONE of our MySQL-Servers. It does not happen on two other remote servers and does not happen on the localhost.

The OS on all remote machines are Debian 5.0.51a-24+lenny4

For the moment I'm using MySQL-Administrator for this server as it works fine.
[17 Nov 2010 13:40] Pat Sinclair
Alfredo:
The authentication problem only happened when trying to use root.  When I use an assigned users login, connection setup works fine, but, just like Niels Fahse explained it is then a "limited" connection, basicly nothing there.
[17 Nov 2010 14:16] Niels Fahse
In fact I am trying to establish the server adminstration connection as root (with all privileges) and get the error mentioned above. This is really mysterious as I can use exactly the same connection to view and edit tables (SQL-Development section).
[18 Nov 2010 13:42] Alfredo Kojima
I got that exact error message (Lost connection to MySQL server at 'reading initial communication packet', system error: 61
You may continue anyway, but some functionality will be unavailable.)

after I stopped the server and tried connecting.
[18 Nov 2010 14:08] Niels Fahse
This is definitly not the solution. The server is running. I cann connect to it in the "SQL Development" section and query tables on the server.
[18 Nov 2010 14:10] Niels Fahse
Ah, btw it is not the EXACTLY same message. My message says "system error: 0" yours is "system error: 61"
[26 Nov 2010 23:25] Alfredo Kojima
Niels, others. I still cannot repeat the error, but have 2 theories. You can try the easiest one by following these steps:

Find db_utils.py in the installation.
Open in an editor and find a line that says 
   params['OPT_READ_TIMEOUT'] = 8
in function connect. It's around line 126.

Change that timeout value from 8 to some higher value, save, start WB and try connecting.

Initially try something high like 600, if it works, reduce the value to find out an approximate value for the lowest value that still works for you.

If that still doesn't solve the problem, please report so we can try the other theory.
[30 Nov 2010 8:12] Niels Fahse
I changed timeout from 8 to 600 -> it works.
I changed it back to 8 -> it still works.

Nice healing. Hope the illness doesn't com back again.
Thanks for the support.
[10 May 2011 18:48] MySQL Verification Team
Have you tried what Alfredo asked in his last comment?. Thanks.
[10 Jun 2011 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".