Bug #56106 Alter routine break code of this routine when exist cyrillic comment
Submitted: 19 Aug 2010 6:01 Modified: 9 Sep 2010 10:00
Reporter: Igor Garikov Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.26 OS:Microsoft Windows (XP)
Assigned to: CPU Architecture:Any
Tags: cyrillic comment

[19 Aug 2010 6:01] Igor Garikov
Description:
can't possible to use cyrillic comment in routine

How to repeat:
-- --------------------------------------------------------------------------------
-- Routine DDL
-- --------------------------------------------------------------------------------
DELIMITER $$

CREATE DEFINER=`xx`@`xx` PROCEDURE `test`(IN in_test INT)
BEGIN

DECLARE l_test INT;

-- Начало

SELECT * FROM test WHERE id=in_test;

-- Продолжение

SET l_test=1;
SET l_test=l_test+2;

END

Click to Apply leads to correct saving of routine.
In console SHOW CREATE PROCEDURE test; views OK, but in workbench Alter Routine break text of routine like this:
-- --------------------------------------------------------------------------------
-- Routine DDL
-- --------------------------------------------------------------------------------
DELIMITER $$

CREATE DEFINER=`xx`@`xx` PROCEDURE `test`(IN in_test INT)
BEGIN

DECLARE l_test INT;

-- Начало процедуры

SELECT * FROM test WHERE id=in_test;

-- Продолжение

SET l_test=1;
SET
[7 Sep 2010 4:36] Alfredo Kojima
Probably a duplicate of bug #56083
[9 Sep 2010 10:00] Mike Lischke
Not exactly a duplicate, since the entire story is different. However, the problem ultimately goes down to the same bug in the underlying text control.