Bug #55883 RQG tests fail on Windows x86 debug_max
Submitted: 10 Aug 2010 14:42 Modified: 21 Sep 2010 6:42
Reporter: Alexander Nozdrin Email Updates:
Status: Closed Impact on me:
None 
Category:Tools: Random Query Generator Severity:S1 (Critical)
Version:M4 (Dahlia) OS:Microsoft Windows
Assigned to: John Embretsen CPU Architecture:Any

[10 Aug 2010 14:42] Alexander Nozdrin
Description:
RQG tests fail on Windows starting from Dahlia.

The tests don't run on 5.5 yet, so it's unknown if they fail in Celosia too.

The tests don't run on other Windows flavors, so may be the failures
are not 'x86 debug_max' specific. The tests however pass on Solaris 10.

How to repeat:
Check out PB.
[10 Aug 2010 14:56] John Embretsen
Indeed, all tests fail on Windows currently with an error message like this:

Installing Master Database
cat: G:/pb2/test/sb_1-2136155-1281437819.13/mysql-5.6.99-m5-win-x86-test/vardirs/log/master.err: No such file or directory
2010-08-10T12:58:52 [3772] runall.pl will exit with exit status 1

This is most likely due to the dependence on MTRv1, which has failed miserably for a couple of months now (if using 5.5-related branches such as mysql-trunk or mysql-next-mr).

More specifically, it is likely that these failures are due to:
 - Bug#54835 (MTR version 1 cannot start server - bootstrap reports unknown InnoDB engine)

This is now supposed to be fixed (since Aug 4), however there is another bug making MTRv1 fail:

 - Bug#55817 (Server in bootstrap mode cannot execute long queries, installation breaks)

There is a workaround in place which is the reason why tests don't fail (as much) on Unix platforms. That workaround is to use runall-new.pl (in Pushbuild: pb2gentest-new.pl), which uses the RQG's own Server module instead of MTR. 

In Pushbuild you can check if the workaround is in use or not by examining RQG logs and looking for pb2gentest.pl (if found, no workaround is used) and pb2gentest-new.pl (if found, workaround is in use).

Unfortunately this workaround does not work reliably on Windows, so it has not been configured to run there. See related bugs Bug#55780, Bug#55310, Bug#55309.
[15 Aug 2010 12:24] Sveta Smirnova
Thank you for the report.

Verified as described. Workaround is not in use.
[16 Aug 2010 8:16] John Embretsen
Bug#55983 (MTR1 produces bootstrap SQL file with wrong syntax, server bootstrap fails) is also a likely root cause.
[18 Aug 2010 7:53] John Embretsen
Fix for Bug#55983 pushed to mysql-next-mr-bugfixing and mysql-trunk-bugfixing 2010-08-17. This seems to have made RQG tests on Windows run properly once again.

I will try to adjust PB2 config so that all RQG tests on Windows use MTRv1 to start the server (pb2gentest.pl) - there is a test or two still trying to use the workaround. We may switch back later if we can resolve the issues with non-MTR server start on Windows.

I am not sure at this time if (and if so, where) Bug#55817 is still an issue for RQG in PB2, so I'll hang around and see.

I will keep an eye on the tests every once in a while, and intend to update this bug report when I have confirmed tests are working on all applicable "main" and -bugfixing branches.

Please speak up if someone notices another surge of RQG test failures.
[21 Sep 2010 6:42] John Embretsen
Pushbuild results for RQG on Windows looking good for the past days.
Assuming the mentioned bug fixes resolved the issue, and closing this bug.