Bug #55820 Invalid node index
Submitted: 7 Aug 2010 8:49 Modified: 12 Aug 2010 17:43
Reporter: Raith Krace Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S2 (Serious)
Version:5.2.26 CE (6 august) OS:Microsoft Windows (Server 2008 R2)
Assigned to: CPU Architecture:Any
Tags: at start, INDEX, invalid, node, sql edito, workbench

[7 Aug 2010 8:49] Raith Krace
Description:
Just installed the latest workbench on 200 R2 and when I open the sql ediror I get an erroe message stating "invalid node index" and asking me to file this bug report. I installed the server yesterday, an had a beta version on workbench OSS thanks to your download page not working. I installed the new version over this.

How to repeat:
Don' really know how because I just open up sql editor and it pops up. Maybe it's related to the old workbench version over which I installed the new version (i.e. not uninstalling the old version previously)

Suggested fix:
Unistalling any workbench version before installing the new one
[8 Aug 2010 5:35] Miguel Solorzano
I couldn't repeat the behavior reported. I installed the version 5.2.26 upgrading the version 5.2.25 ( without to uninstall 5.2.25).
[9 Aug 2010 10:04] Susanne Ebrecht
Please provide general log and error log from server.
[9 Aug 2010 10:18] Raith Krace
Sorry, I see no error in the Windows Event Log regarding MySQL. The problem does not reoccur when opening Workbench a second time in the same session.
[9 Aug 2010 13:25] Miguel Solorzano
So that issue only happens after a reboot/shutdown of the machine?. Thanks in advance.
[9 Aug 2010 15:41] Raith Krace
Yes, only on restart and shutdown. If i just log off and the login again it works normally. As far as I can tell it does not impair functionality but if I can help you with more information please let me know.
[12 Aug 2010 12:00] Susanne Ebrecht
This looks like a Windows problem to me.

When you boot your machine then it's up very quick but there are still processes in background running to finish booting and start all services.

You description really looks like that Windows just not finished booting yet with something that Workbench needs.
[12 Aug 2010 17:43] Raith Krace
Restarted the server and after about 25 minutes after fully loading opened up workbench sql editor. Same bug.