Bug #55759 Table editor does not update when new table selected in EER interface
Submitted: 5 Aug 2010 6:15 Modified: 15 Oct 2010 13:38
Reporter: Jonathon Coombes Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S3 (Non-critical)
Version:5.2.25 OS:Any
Assigned to: Alfredo Kojima CPU Architecture:Any
Tags: EER, modeling, wb, workbench

[5 Aug 2010 6:15] Jonathon Coombes
Description:
Selecting a different table in the EER diagram changes the description list to the new table name, but not the table editor.

How to repeat:
Load/create an EER diagram with more than one table.
Double click one table to display table editor and note the names in the description list and the table tab.
Single click on another table to select it and note that the description list changes, but not the table editor tab.
Double click the second table to change the table editor.

Suggested fix:
Change table tab as well as the description list
[5 Aug 2010 7:03] Roel Van de Paar
Verified as described. There's another issue once this has happened. When then closing the tab editor, if you double click the first table again, the tab editor does not re-open. When clicking the second table it does.
[16 Aug 2010 0:53] Roel Van de Paar
See bug #55994 - likely same cause, different result.
[14 Sep 2010 5:01] Alfredo Kojima
This is not a bug. You have to double-click the table to change the object being edited in the table editor.
[14 Sep 2010 6:26] Jonathon Coombes
I can understand the double click activating the table object, but there is inconsistencies it would seem in how this works.

If you single click on the table, the description list displays the new table name, but the table is not displayed in the table editor. I think it is very confusing having the description list display one table, and the editor showing another? It would be more consistent to make the description list change on the double click in the table editor and not by the single click.

Also, remember that Roel pointed out another aspect of this bug:

"When then closing the tab editor, if you double click the first table
again, the tab editor does not re-open. When clicking the second table
it does."
[15 Oct 2010 13:38] Johannes Taxacher
As mentioned by Alfredo Kojima already, this behavior is by design.
The difference between the two screen-items is, that the description-pane (as well as the properties-pane) are singleton objects in the UI which always display information of the selected item on the canvas, where the table-editor is a different kind of UI-item which can be open multiple times for different table.

As for the "won't reopen" problem, i cannot reproduce that problem in recent releases.