Bug #5572 Files stated to exist in manual are not present
Submitted: 14 Sep 2004 16:32 Modified: 15 Sep 2004 1:33
Reporter: David Nightingale Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Documentation Severity:S3 (Non-critical)
Version:4.0.20a OS:Microsoft Windows (XP Pro)
Assigned to: CPU Architecture:Any
Triage: D4 (Minor)

[14 Sep 2004 16:32] David Nightingale
Description:
Hello, 

I am pretty new to all of this. I have Mysql working finally, the accounts secured or deleted that needed to be. I even have phpmyadmin working with cookies. 

Whew hoo!!! When I log into phpmyadmin of course I get the message that you get when linked tables is not setup. So I cant have that. The instructions looked pretty straight forward and I was relieved to find out there was a script I could simply run from phpmyadmin to create the tables automatically. However, the script is not where the instructions say it should be. Nothing even close is there. 

Take a look: 
"For a whole set of new features (bookmarks, comments, SQL-history, PDF-generation, field contents transformation, etc.) you need to create a set of special tables. Those tables can be located in your own database, or in a central database for a multi-user installation (this database would then be accessed by the controluser, so no other user should have rights to it). 

Please look at your scripts/ directory, where you should find a file called create_tables.sql. (If you are using a Windows server, pay special attention to FAQ 1.23). 

If your MySQL server's version is 4.1.2 or later, please use create_tables_mysql_4_1_2+.sql instead, for a new installation. 

If you already had this infrastructure and upgraded to MySQL 4.1.2 or later, please use upgrade_tables_mysql_4_1_2+.sql." 

Just to make sure I even downloaded the zip install file of the latest general release, extracted to a folder, checked the scripts directory and still....NO SCRIPT! I AM LOSING MY MIND!!! 

Please Help me....8-( 

Thanks! 

David 

How to repeat:
Download the build. Unzip. Look in the scripts directory for:

create_tables_mysql_4_1_2+.sql
and
use upgrade_tables_mysql_4_1_2+.sql

if its not there as stated in the instructions for setting up Linked Tables, you have a successful repeat. 8-)

DN

Suggested fix:
Improve the "Windows/IIS" specific instructions.  I would like to see them treated seperately with no assumptions made as to what is "The same" between a windows and unix configuration. Include the scripts that are listed in the manual.

Thanks!
[14 Sep 2004 18:09] Paul Dubois
The scripts that you refer to are not part of a MySQL
distribution.  Are you talking about the phpMyAdmin
documentation?
[14 Sep 2004 21:53] David Nightingale
You know I assumed this was being pulled from mysql because it refers to a script directory which my PHP install does not have but the mysql install DOES have. This looks like an error on my part. The other thing I was thinking is that I thought I was unlocking extra features within MYSQL but in fact it looks like it actually is expanding phpmyadmin functionality. 

Sorry about that. Now I just need to figure out why the phpmyadmin manual is listing sql scripts that dont exist in the distribution I have.

Thanks for your patience

David
[15 Sep 2004 1:33] Paul Dubois
Thanks for the feedback. Yes, this looks like a phpMyAdmin
issue and not a MySQL issue.  It appears that the phpMyAdmin
project has a page where you can file a report at:

http://www.phpmyadmin.net/home_page/feedback.php

Thanks.