Bug #55529 Cannot start MySQL service (or server) after clean fresh install
Submitted: 24 Jul 2010 7:18 Modified: 14 Dec 2016 21:29
Reporter: John DeRegnaucourt Email Updates:
Status: Unsupported Impact on me:
None 
Category:MySQL Server: Installing Severity:S1 (Critical)
Version:5.5.5 OS:Microsoft Windows (x64 essentials)
Assigned to: CPU Architecture:Any
Tags: service server not starting windows x64

[24 Jul 2010 7:18] John DeRegnaucourt
Description:
Below is the exact output I receive when trying to start MySQL 5.5.5b

C:\MySQL5.5\bin>mysqld.exe --console
100724  3:04:36 [Note] Buffered information: Performance schema disabled (reason: start parameters).

100724  3:04:36 [Note] Plugin 'FEDERATED' is disabled.
InnoDB: The InnoDB memory heap is disabled
InnoDB: Mutexes and rw_locks use InnoDB's own implementation
InnoDB: Compressed tables use zlib 1.2.3
100724  3:04:38  InnoDB: highest supported file format is Barracuda.
InnoDB: The log sequence number in ibdata files does not match
InnoDB: the log sequence number in the ib_logfiles!
100724  3:04:38  InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
100724  3:04:38  InnoDB: Assertion failure in thread 4068 in file ..\..\..\mysql-5.5.5-m3\storage\innobase\fsp\fsp0fsp.c line 2103
InnoDB: Failing assertion: inode
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.1/en/forcing-recovery.html
InnoDB: about forcing recovery.
100724  3:04:38 - mysqld got exception 0xc0000005 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

key_buffer_size=30408704
read_buffer_size=65536
max_used_connections=0
max_threads=800
thread_count=0
connection_count=0
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 293752 K bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

thd: 0x0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
000000014029AB7C    fseg_inode_get()[fsp0fsp.c:2103]
000000014029AE67    fseg_n_reserved_pages()[fsp0fsp.c:2439]
000000014025DF3A    ibuf_init_at_db_start()[ibuf0ibuf.c:537]
00000001402BB91F    dict_boot()[dict0boot.c:449]
00000001402367A0    innobase_start_or_create_for_mysql()[srv0start.c:1625]
000000014022D9B0    innobase_init()[ha_innodb.cc:2423]
00000001400233B6    ha_initialize_handlerton()[handler.cc:476]
000000014001CC7C    plugin_initialize()[sql_plugin.cc:1052]
0000000140021FD9    plugin_init()[sql_plugin.cc:1338]
000000014000C01B    init_server_components()[mysqld.cc:4165]
000000014000CC60    win_main()[mysqld.cc:4764]
000000014000D0A8    mysql_service()[mysqld.cc:4951]
000000014000D393    mysqld_main()[mysqld.cc:5137]
00000001403AC857    __tmainCRTStartup()[crt0.c:266]
0000000077D596AC    BaseProcessStart()
The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.

C:\MySQL5.5\bin>

How to repeat:
I completely uninstalled and then re-installed MySQL 5.5.5b.  I used the windows uninstaller to first uninstall the failed installation.  I then scrubbed clean the MySQL5.5 folder, and the location for the schema (this defaults to a folder deep under the /documents and settings/user/application data/....).  I set that c:\data instead.

When trying to start as a windows service, I tried both the 'Local System Account' and using the Administrator account.  Server failed to start.

I cannot get an instance of 5.5.5b

Has the installation been tested where neither default directory is used?
[24 Jul 2010 9:41] Elena Stepanova
See bug#55169 in regard to non-default paths; although, not sure why the service would not start, it did for me if I indeed cleaned up both the default data folder and the binary installation folder, including the configuration file. 

Also, the data folder might default not to 'documents and settings/<user>/application data/...', but to 'documents and settings/all users/application data/...'
[24 Jul 2010 9:48] Elena Stepanova
My previous comment assumed that the output relates to an attempt to start the server *before* you the clean installation was performed, i.e. you tried to upgrade, got the assertion, removed everything completely and tried the clean installation (and it failed somehow). If it is the output of the presumably clean installation, apparently it was not quite clean since InnoDB found log and data files?
[24 Jul 2010 14:00] John DeRegnaucourt
I finally got the installation working.  To do so, I had to remove the non-default folders (c:\mysql5.5, c:\data) AND the \documents and settings\all users\mysql\*

I do not understand why I had to remove more than the folders I created.  But, nonetheless, it is working now.

Thanks for looking into this.
[26 Jul 2010 15:24] MySQL Verification Team
When you uninstalled are you sure have removed the older my.ini file?. Thanks in advance.
[26 Jul 2010 17:13] John DeRegnaucourt
Yes, I removed the older my.ini file.  Uninstalling and removing c:\MySQL5.5 and removing c:\data was not enough to be able to re-install.  I had to go to (this is XP 64-bit), c:\documents and settings\All Users\Application Data\" and remove MySQL there too.  Once I removed that folder, I was able to install without issues.
[29 Sep 2010 11:07] Susanne Ebrecht
We fixed bug #55169 and would like to plead you to test again with actual tree.
[29 Oct 2010 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[28 Feb 2011 11:20] MySQL Verification Team
See http://bugs.mysql.com/bug.php?id=60264.
[14 Dec 2016 21:29] Yngve Svendsen
Posted by developer:
 
MySQL Installer for Windows has superseded the older, plain msi installers as the preferred tool for installing MySQL. Thus closing this.