Bug #55514 Collation of table does not get saved correctly --
Submitted: 23 Jul 2010 14:57 Modified: 23 Jul 2010 17:41
Reporter: a. p. Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S3 (Non-critical)
Version:5.2.25 CE OS:Microsoft Windows (7 x64)
Assigned to: CPU Architecture:Any

[23 Jul 2010 14:57] a. p.
Description:
I have a database reverse engineered and some tables in there. All tables are stored in InnoDB format. When i have the EER Diagram in front of me i can right click on the database in the "Catalog Tree" and click "Edit Schema...". Then there is a popup window at the bottom of the application where i can set the default "Collation" for the database (above the "Name" property). While i do not close the diagram the collation is "saved". But when i close it and open it again the "Collaction" says "Server Default" and not the set value. When i close the application and reopen it then the collation says "Server Default" too.

How to repeat:
See the description.
[23 Jul 2010 17:37] Valeriy Kravchuk
This is a duplicate of bug #55152 it seems.
[23 Jul 2010 17:41] a. p.
Although this has nothing to do with this problem: when I search for collation I have not found the linked bug report. And this was a problem because I have not seen the page selectors :( Perhaps someone can accentuate them.