Bug #55420 OverviewBE::get_node: invalid node 0.0.2
Submitted: 21 Jul 2010 0:42 Modified: 10 Aug 2010 6:51
Reporter: Park Walker Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.25 OS:Microsoft Windows (XP SP3)
Assigned to: CPU Architecture:Any

[21 Jul 2010 0:42] Park Walker
Description:
Error message was received after selecting an existing connection on a remote machine. I had just upgraded from an earlier version and the application ran automatically.

How to repeat:
Does not happen on startup; maybe an installation problem?
[21 Jul 2010 1:06] MySQL Verification Team
Thank you for the bug report. That issue happens constantly or just after the install process?.
[21 Jul 2010 5:25] Park Walker
I only experienced it on the auto-execute immediately following installation but I've only run the program once since then. I'll post an update if I see it again.
[5 Aug 2010 19:30] [ name withheld ]
This bug happens to me when I try to open an existing connection under SQL Development.  It starts loading the connection and SQL Editor tab with databases on the left and the error pops up.  It just happened twice in a row.  The first time I had to close Workbench.  The second time I just closed the tab and could try again and the third try it worked fine and I could query stuff.  I also have 5.2.25.  I think I edited that connection to adjust the IP address in the past but I've been using that connection for a few days.  I haven't had it happen with a different connection but this one is the one I use most.
[6 Aug 2010 21:47] [ name withheld ]
I just got a "invalid node 0.0.0" for the first time in the same situation too.  Now it seems like it happens often on the first time I try to open SQL Editor for the connection.  I haven't been able to get the error to pop when opening a different connection so far though.  Well, after opening and trying it many times, it hasn't erred for a while now.
[8 Aug 2010 15:17] Valeriy Kravchuk
All reporters:

Please, check with a newer version, 5.2.26, and inform about the results.
[9 Aug 2010 16:28] [ name withheld ]
I received "Invalid node index" error now, first try after install.  It seems to be similar error.  Workbench is frozen after closing the connection tab.  Several subsequent tries did not bring up the error again.
[9 Aug 2010 20:47] [ name withheld ]
I received this error again, this time connecting to localhost MySQL just after creating the connection so different connection.  Frozen again when I closed connection tab.  When I kill and reopen Workbench, the connection I made is gone, but after recreating, works next try.

MySQL Workbench has encountered a problem
Invalid node index
...

Note that there isn't any "OverviewBE::get_node:" there anymore (perhaps should update bug report for this and 5.2.26).  Also I forgot to mention I can see the databases on the left, but when I try to expand it says "fetching..."
[10 Aug 2010 6:51] Susanne Ebrecht
Many thanks for writing a bug report.

This is a duplicate of bug ##52648