Bug #55380 OverviewBE::get_node: invalid node 0.0.0
Submitted: 19 Jul 2010 20:45 Modified: 22 Jul 2010 6:04
Reporter: Michael Zeman Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.25 CE OS:Microsoft Windows (XP Pro SP3)
Assigned to: CPU Architecture:Any

[19 Jul 2010 20:45] Michael Zeman
Description:
When I start Workbench 5.2.25 CE, sometimes an error window pops up with the above message "OverviewBE::get_node: invalid note 0.0.0"

Workbench does connect to the server, and after I close the error box I can use workbench normally on the connected server.  I don't see anything wrong or acting strangely.

How to repeat:
Launch Workbench 5.2.25 CE.

Suggested fix:
I don't know what the error is, or what it is supposed to mean.  If it isn't critical (doesn't appear to be), remove it. :)
[19 Jul 2010 20:48] Michael Zeman
I should add to the above, this error pops up when I try to connect to a server using SQL editor.

In other words:

1. Launch MySQL Workbench 5.2.25 CE - Splash screen comes up, and loads fine.  Sits at the main menu.

2. Double click on a server under the SQL Editor window - Splash screen comes up saying that it is connecting.  Microsoft error window pops up with the above error.  Clicking "Close" closes the error window, and SQL editor is connected to the server and ready to be used.
[19 Jul 2010 21:09] MySQL Verification Team
Thank you for the bug report. Are you able to provide a screen-shot showing the item #2 of your prior comment?. Thanks in advance.
[19 Jul 2010 21:46] Michael Zeman
Screenshot

Attachment: wb bug.jpg (image/jpeg, text), 138.61 KiB.

[19 Jul 2010 21:48] Michael Zeman
One further comment that I noticed.  This error only happens the first time it is launched.  If I reboot the computer and, after XP comes up and is ready to use, I launch Workbench then I get that error.  If I shut workbench down and relaunch it then this error does not appear.  Reboot XP, launch, and error is back.

Hope that helps!
[20 Jul 2010 9:26] Susanne Ebrecht
Windows is doing lots of stuff in background after you are already able to use it.

Maybe it just not finished some setup/boot stuff ...

How long did you wait after Windows was up before you started Workbench?

Will it also happen after you waited e.g. 30 Minutes?
[20 Jul 2010 14:16] Michael Zeman
Yes.  Yesterday when I reported the bug my computer had been running for about 3 days without a reboot. I had used the computer for several hours before needing to check something on a server, launched Workbench, launched the SQL Editor and received the error.

After being requested to give a screenshot I relaunched it and did not get the error.  Rebooted for giggles, and was able to get the error.

I'll reboot again now, work for a few hours (do some web browsing as well, so networking is definitely up and running), and then launch WB.  I'll post the results.
[20 Jul 2010 16:36] Michael Zeman
Several things of noteworthiness:

1. Rebooted computer, worked with it for 2 hours prior to launching WB (including web browsing so networking is confirmed to be up and running), launched WB and SQL Editor and the error occurs.

2. Rebooted, disabled all antivirus (AVG) and spyware (Spybot Search and Destroy & Super Anti-spyware), launched WB and SQL Editor and the error occurs.

3. Some time during all of the above the error message changed to "invalid node 0.0.1"  I'm not sure when because, quite frankly, I've been more concerned with getting rid of it and have been clicking Close.  I just noticed it now, however.

As mentioned earlier on, I don't know what that bug message is supposed to be pointing out.  Can someone let me know what that error means, and then I can maybe try to do some different configurations to see what might be causing it?

And again, this error seems to have *no* effect on the program.  After closing the error message SQL Editor works just fine.  I do not have to relaunch the program.  If I do relaunch the program without a reboot of the computer, then it launches without the error.
[22 Jul 2010 6:04] Susanne Ebrecht
This is a duplicate of bug #52648