Bug #55356 Workbench unable to fetch schema/tables
Submitted: 19 Jul 2010 9:30 Modified: 2 Aug 2010 9:56
Reporter: dfg dfg Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S2 (Serious)
Version:5.2.25 OS:Microsoft Windows (7 prof 64bit)
Assigned to:
Tags: Fetching

[19 Jul 2010 9:30] dfg dfg
Description:
OS: Windows 7 Prof. 64-Bit
MySQL: 5.1.42-community 64-Bit
Workbench: 5.2.5 Revision 6303

Workbench can only fetch scheme for the first database, but tables are not shown in the main window. Workbench is unable to fetch the scheme of any other database on the same server. See screenshot. Seems to be exactly the same problem like in #53513. I have no problem with Toad or Navicat and the same database server.

Snippet from my.ini (don't know if helpful):
max_connections=100
query_cache_size=0
table_cache=256
tmp_table_size=34M
thread_cache_size=8

#*** MyISAM Specific options
myisam_max_sort_file_size=100G
myisam_sort_buffer_size=68M
key_buffer_size=54M
read_buffer_size=64K
read_rnd_buffer_size=256K
sort_buffer_size=256K

#*** INNODB Specific options ***
innodb_additional_mem_pool_size=3M
innodb_flush_log_at_trx_commit=1
innodb_log_buffer_size=2M
innodb_buffer_pool_size=105M
innodb_log_file_size=53M
innodb_thread_concurrency=8

How to repeat:
occurs every time on this installation
[19 Jul 2010 9:37] Valeriy Kravchuk
Do you have any suspicious messages in the error log of MySQL server?
[19 Jul 2010 17:58] dfg dfg
Found this:

100719 11:01:01 [ERROR] Column count of mysql.proc is wrong. Expected 20, found 16. The table is probably corrupted
[20 Jul 2010 9:51] Susanne Ebrecht
The error message shows that you once upgraded from MySQL 5.0 to MySQL 5.1 but you forgot to run mysql_upgrade.

Please try this first. Run mysql_upgrade.
[20 Jul 2010 16:09] dfg dfg
I've made a dump of the whole server, made a new installation and imported all database and tables. So maybe the corrupt table was the reason.

But I think at least the error handling inside Workbench is broken and there is still something to fix. Endless "fetching" messages on all databases, tables, views, except the first database are strange. And Toad, Navicat and other Tools hav no problems under the same conditions.
[21 Jul 2010 1:05] Roel Van de Paar
See bug #55008
[2 Aug 2010 9:56] Susanne Ebrecht
The problem is not really related to Workbench. Its a problem of upgrading MySQL.

Anyway ...

You said that it helped and all is working fine now.

I will close this bug report now. If you still have problems then feel free to re-open it.