Bug #55239 Not enough memory to complete the operation
Submitted: 13 Jul 2010 23:08 Modified: 14 Jul 2010 12:29
Reporter: Michael Reichner Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S1 (Critical)
Version:5.2.25 OS:Microsoft Windows (Vista basic home)
Assigned to: CPU Architecture:Any

[13 Jul 2010 23:08] Michael Reichner
Description:
I was editing the automatically generated EER diagram following the reveng of a 78 table data model.  Got an error along the lines of that stated in Synopsis.  Task Manager shows MW using over 1GB of memory

How to repeat:
Create a sufficiently large EER diagram and perform a large amount of arranging the tables.
[14 Jul 2010 0:04] MySQL Verification Team
Thank you for the bug report. Could you please provide the output of Help->System Info. Thanks in advance.
[14 Jul 2010 0:06] MySQL Verification Team
Please provide the version are you using too. Thanks.
[14 Jul 2010 1:36] Michael Reichner
Upon subsequent review of documentation, it seems that I may be using am underpowered system.

Help->System Info:

MySQL Workbench CE for Windows version 5.2.25
Data Directory: C:\Program Files\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
Rendering Mode: OpenGL is available on this system, so OpenGL is used for rendering.
OpenGL Driver Version: 2.1.1
OS: Microsoft Windows Vista Home Basic Edition (build 6000), 32-bit
CPU: AMD Athlon(tm) 64 Processor 3800+, 1.4 GiB RAM
Video adapter info:
Adapter type: NVIDIA GeForce 6150SE    
Chip Type: GeForce 6150SE
BIOS String: Version 5.61.32.20.1
Video Memory: 65536 KB
[14 Jul 2010 6:10] Valeriy Kravchuk
So, formally this is not a bug.
[14 Jul 2010 12:29] Michael Reichner
I am indeed at fault for failing to understand the minimum memory requirement prior to using the application.

The error did, however, irrecoverably hang the application - every time I tried to close an EER diagram tab, the same error would display.

And seriously, 4GB minimum?
[14 Jul 2010 16:43] Edwin DeSouza
Minimum System Requirements:
http://wb.mysql.com/?page_id=30