Bug #5523 Test failure: 'ctype_uca'
Submitted: 10 Sep 2004 22:08 Modified: 14 Sep 2004 8:06
Reporter: Joerg Bruehe Email Updates:
Status: Closed Impact on me:
Category:MySQL Server: Compiling Severity:S1 (Critical)
Version:4.1.5 OS:IBM AIX (AIX 5.1)
Assigned to: Alexander Barkov CPU Architecture:Any

[10 Sep 2004 22:08] Joerg Bruehe
On 'pdslib51', the test 'ctype_uca' fails with this result:

Below are the diffs between actual and expected results:
*** r/ctype_uca.result  Thu Sep  9 22:26:18 2004
--- r/ctype_uca.reject  Sat Sep 11 01:02:05 2004
*** 1896,1903 ****
  SELECT * FROM t1 WHERE c LIKE _ucs2 0x039C0025
  COLLATE ucs2_unicode_ci ORDER BY c;
- ÎÏΎα᜷Ì
  CREATE TABLE t1 (c varchar(255) NOT NULL COLLATE utf8_unicode_ci, INDEX (c));
  INSERT INTO t1 VALUES (CONVERT(_ucs2 0x039C03C903B403B11F770308 USING utf8));
--- 1896,1901 ----

Running it with '--debug' gives the same differences.

How to repeat:
Run the test (suite).
[10 Sep 2004 22:16] Joerg Bruehe
The same test failure occurs on 'pegasos1'.
[13 Sep 2004 18:54] Joerg Bruehe
The same error occurs on 'octane2' (IRIX64).
[13 Sep 2004 19:18] Matt Wagner
The same error occurs on 'aix43' (AIX 4.3)
[14 Sep 2004 7:51] Joerg Bruehe
Now also on pdslib51.
[14 Sep 2004 8:06] Alexander Barkov
Thank you for your bug report. This issue has been committed to our
source repository of that product and will be incorporated into the
next release.

If necessary, you can access the source repository and build the latest
available version, including the bugfix, yourself. More information 
about accessing the source trees is available at