Bug #55160 Drop Routine from UI leaves icons in object browser
Submitted: 11 Jul 2010 1:39 Modified: 21 Jul 2010 19:09
Reporter: Jack Yasgar Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.19 r5680, 5.2.25 OS:Microsoft Windows (XP Pro)
Assigned to: CPU Architecture:Any

[11 Jul 2010 1:39] Jack Yasgar
Description:
When a routine is dropped, it moves all the other routines up, however empty icons remain at the bottom of the listing.

How to repeat:
Open the Routines folder in the Object Browser. Right click a routine and Select Drop Routine...

After dropping the routine, scroll to the bottom of the list of routines and there will be an empty icon.
[11 Jul 2010 1:42] Jack Yasgar
Image of Object Browser

Attachment: Bug55160.jpg (image/jpeg, text), 54.58 KiB.

[11 Jul 2010 8:28] Valeriy Kravchuk
I do not see this problem with 5.2.25 on Mac. So, please, check with a newer version, 5.2.25.
[11 Jul 2010 21:09] Jack Yasgar
I have installed 5.2.25 CE R6303 for Windows and I see the same issue as before.
[12 Jul 2010 4:56] Valeriy Kravchuk
Thank you for the bug report. Verified just as described with 5.2.25 on Windows XP.
[21 Jul 2010 19:09] Alfredo Kojima
This is a duplicate of bug #52878, which also happens for tables and other object types