Bug #55105 Some PB2 tests fail sporadically with SIGSEGV in inline_mysql_mutex_lock.
Submitted: 8 Jul 2010 23:17 Modified: 13 Nov 2010 2:20
Reporter: Luis Soares Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Performance Schema Severity:S3 (Non-critical)
Version:next-mr OS:Any
Assigned to: Marc Alff CPU Architecture:Any
Triage: Triaged: D2 (Serious)

[8 Jul 2010 23:17] Luis Soares
Description:
Some tests fail sporadically on PB2 with SIGSEGV after 
kill_server_thread is called. Some examples of failing tests:

- rpl.rpl_heartbeat_basic
- main.server_uuid
- binlog.binlog_max_extension
- rpl.rpl_trigger
- main.innodb-autoinc

xref shows that these kind of failures were observed earlier this 
year (back in Jan and Feb). Then, no more failures were observed
until early June, which is when they showed up again.

List of failures: http://tinyurl.com/2vxhkuo

How to repeat:
Just check the xref link: http://tinyurl.com/2vxhkuo

Suggested fix:
.
[14 Jul 2010 21:13] Sveta Smirnova
Thank you for the report.

Verified as described using link provided. Not repeatable in my environment.
[27 Aug 2010 15:31] Marc Alff
Possibly related to bug#56324
[14 Sep 2010 21:50] Marc Alff
This crash is caused by a race condition between the kill_server_thread and main, during shutdown.

It's a spurious failure, hard to reproduce.
It has been mostly seen in the next-mr tree I think because this is the code base which is built the most frequently in development, but the same bug most likely exists in 5.5 and trunk.

This issue is fixed by the fix for bug#56324
[14 Sep 2010 22:01] Marc Alff
Pushed into:
- mysql-5.5-bugfixing
- mysql-trunk-bugfixing
- mysql-next-mr-bugfixing

by the fix for bug#56324
[13 Nov 2010 2:21] Paul Dubois
Noted in 5.5.7, 5.6.1 changelogs.

The server could crash during shutdown due to a race condition
relating to Performance Schema cleanup.