Bug #55009 Workbench Unexpected Error OverviewBE::get_node:invalid node 0.0.1
Submitted: 5 Jul 2010 17:53 Modified: 6 Aug 2010 16:59
Reporter: Deepak Khosla Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.25 OS:Microsoft Windows (XP SP3)
Assigned to: CPU Architecture:Any

[5 Jul 2010 17:53] Deepak Khosla
Description:
Tried conencting with IP address set to 127.0.0.1 for a connection (which forwards over ssh). If set to localhost, no issues.

How to repeat:
Set hostname to 127.0.0.1. 
Change it to localhost to resolve.
[5 Jul 2010 18:10] MySQL Verification Team
I couldn't repeat on Vista Home Premium 64-bit.
[5 Jul 2010 18:22] Deepak Khosla
I went back and retried it by changing back to 127.0.0.1 - this time no popo-up error.
This was a new install. Maybe only on startup the first time? I cannot reproduce it anymore.
We can close it.
[5 Jul 2010 20:42] MySQL Verification Team
Thank you for the feedback.
[6 Jul 2010 0:50] Deepak Khosla
Fetching message

Attachment: CropperCapture[142].jpg (image/pjpeg, text), 215.66 KiB.

[6 Jul 2010 0:51] Deepak Khosla
Error message

Attachment: CropperCapture[141].jpg (image/pjpeg, text), 128.80 KiB.

[6 Jul 2010 0:53] Deepak Khosla
Hi
I saw this again. Thsi tiem the first time I accessed 'Edit table'. I am attaching the image for the error message. Starnge thing is that it accessed the table already! After I close the error, I can see 'fetching...' on the Object Browser (right). Image also attached.
[5 Aug 2010 7:49] Roel Van de Paar
Marking this as a duplicate of bug #52648 (Workbench OverviewBE::get_node:invalid node 0.0.0).

The "fetching" issue is another problem, which likely indicates you forgot to run mysql_upgrade after upgrading from an earlier release. Please check and let us know.
[5 Aug 2010 13:46] Deepak Khosla
We usually run mysql_upgrade as a standard practice after install. Not sure how I can tell if it has been run?
[5 Aug 2010 23:06] Roel Van de Paar
If you're using a recent version of MySQL, just run it again (please take precautions like stopping your application traffic, taking a backup etc.). What does it say?

C:\mysql\bin>mysql_upgrade
Looking for 'mysql.exe' as: C:\mysql\bin\mysql.exe
Looking for 'mysqlcheck.exe' as: C:\mysql\bin\mysqlcheck.exe
This installation of MySQL is already upgraded to 5.1.49, use --force if you still need to run mysql_upgrade
[6 Aug 2010 16:59] Deepak Khosla
Thanks. Our DB is on Linux and looks like it already has been updated to a newer release since I reported this. Our admins say they always run this. (They are not sure if on Linux it reports that 'it has been run before' and they don't want to rerun it in case it causes issues ..).