Bug #54911 Inserts not created when reverse engineering
Submitted: 30 Jun 2010 10:38 Modified: 20 Jun 2013 21:21
Reporter: Patrick Timm Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S2 (Serious)
Version:5.2.24 CE RC OS:Microsoft Windows (7)
Assigned to: CPU Architecture:Any
Tags: reverse engineering inserts
Triage: Needs Triage: D5 (Feature request)

[30 Jun 2010 10:38] Patrick Timm
Description:
I have a table on my server with 800 rows. These rows are an important part of my initial state for the project, hence it would be nice to have them as part of my model.

As I do not want to handcode all these rows, and I have not found a way to insert raw sql insert statements, I tried reverse engineering. The table is created as it should but there are no inserts.

How to repeat:
Create a table on the server and enter some data. Then reverse engineer it.

Suggested fix:
Make a checkbox in the reverse engineering dialog that says something like "create inserts?"
[30 Jun 2010 11:00] Valeriy Kravchuk
Thank you for the feature request.
[9 Jul 2010 4:44] Valeriy Kravchuk
Bug #55102 was marked as a duplicate of this one.
[4 Nov 2010 17:53] raffaele raffaeel
I'd like to know if this feature is been implemented?
[20 Jun 2013 21:21] Alfredo Kojima
This feature is too dangerous and would be way too easy to be misused with bad consequences (users importing entire big databases into a model). It's now also possible to import CSV files in a standard inserts editor.