Bug #54904 LOAD DATA INFILE crashes without error
Submitted: 29 Jun 2010 22:08 Modified: 30 Jun 2010 4:04
Reporter: Ian King Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.24 OS:Mac OS X
Assigned to: CPU Architecture:Any
Tags: data, editor, load, SQL

[29 Jun 2010 22:08] Ian King
Description:
Using the statement

USE iannetwork;
LOAD DATA LOCAL INFILE '/Users/iking/Desktop/territorycodes.csv'
INTO TABLE territory
FIELDS TERMINATED BY ','
LINES TERMINATED BY '\n'
(zipprefix, lrepid, frepid, stateid); 

causes the entire workbench to close without an error.

I started using generic syntax, it errorred telling me table did not exist, so I used my table name.  Then it cycled through each generic field and I replaced it with the legitimate field from the table.  Once it can find the table and correct field names is when it crashes.

How to repeat:
Create a generic CSV file with 4 fields, load with data.

Create a table with an id field (primary key, not null, auto increment) and four additional fields to hold the data from your CSV file.

Use the query:

USE [db_name];
LOAD DATA LOCAL INFILE '/[path]/[filename].csv'
INTO TABLE [table_name]
FIELDS TERMINATED BY ','
LINES TERMINATED BY '\n'
([field1], [field2], [field3], [field4]);
[30 Jun 2010 4:04] Valeriy Kravchuk
This is a duplicate of Bug #49694.