Bug #54900 view editor reformats underlying SELECT text
Submitted: 29 Jun 2010 18:28 Modified: 30 Jun 2010 12:28
Reporter: John McKenzie Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.24 OS:Microsoft Windows (xp pro sp 3)
Assigned to: CPU Architecture:Any
Tags: view editor format

[29 Jun 2010 18:28] John McKenzie
Description:
After entering or modifying SELECT statement of VIEW definition, Workbench reformats the text to a single line rather than keeping the newlines and tabs of the original text.

How to repeat:
Create new view
Enter SELECT statement on mulitple lines
Press APPLY button on editor dialog
Press APPLY SQL button after on confirmation dialog
Press FINISH button on final dialog
Re-open editor for the view
 Original multiline text is now on single line.
[29 Jun 2010 21:31] MySQL Verification Team
Thank you for the bug report. Could you please try version 5.2.24. Thanks in advance.
[30 Jun 2010 0:40] John McKenzie
Miguel,
Thank you for the reply.
Version 5.2.24 still compresses the text into a single line immediately after pressing the APPLY button.
[30 Jun 2010 4:01] Valeriy Kravchuk
Actually, it is MySQL server that re-formats (does not preserve original format for) SELECT statement that defines the view.

I think this is a duplicate of bug #52004.
[30 Jun 2010 11:34] John McKenzie
This appears to, indeed, be a duplicate of bug #52004.
The reformatting becomes a particular problem as the length of the underlying SELECT statement increases - making it difficult to edit.
[30 Jun 2010 12:28] Valeriy Kravchuk
Duplicate of bug #52004.