Bug #54897 Diagram of EER model created from existing database not displaying correctly.
Submitted: 29 Jun 2010 16:14 Modified: 11 Aug 2010 10:54
Reporter: Steve Small Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S3 (Non-critical)
Version:5.2.26 OS:Microsoft Windows (XP Pro SP3)
Assigned to: CPU Architecture:Any
Tags: diagram, EER, model, not displaying, not showing

[29 Jun 2010 16:14] Steve Small
Description:
When trying to create an EER model of an existing database located on a remote server, the resulting diagram does not display correctly. It will show the placeholder (tab) for the new diagram, and the wizard will complete successfully, however, the content of the diagram is just a frozen image of whatever was displayed in that space on the screen before giving focus to the diagram.

How to repeat:
At 'Home' screen in Workbench, click 'Create EER Model From Existing Database." Retrieve stored connection settings from 'Stored Connection' drop-down. Next. DBMS connection and fetch info executed successfully. Next. Select one database. Next. Object info fetch executed successfully. Next. Then, since this database has many tables, I wanted to filter out just three. So filter in (include) three tables, and filter out (exclude) any other objects (in this case, filter out one view object. Execute >. At this point, it should say 'Reverse Engineering Progress,' operation completed successfully. The new EER diagram appears in the main window, behind the wizard box. However, there are no objects visible, and moving the wizard window leaves trails over the diagram space. Next and Finish closes the wizard, however the diagram is still frozen with the content that previous occupied that space on the screen (as of now, switching back to Workbench keeps the parts of this web page that occupy the space of the diagram content).
[29 Jun 2010 16:18] Steve Small
Here is what the diagram screen looks like after switchnig between Firefox and Workbench.

Attachment: workbench_1.JPG (image/jpeg, text), 104.96 KiB.

[29 Jun 2010 17:13] Valeriy Kravchuk
Please, send the results from Help > System Info menu item. What version of MySQL server are you working with?
[29 Jun 2010 19:08] Steve Small
Here are the resutls in Help -> System Info: 

MySQL Workbench CE for Windows version 5.2.24
Data Directory: C:\Documents and Settings\a1\My Documents\MySQL Workbench 5.2.24 CE
Cairo Version: 1.8.8
Rendering Mode: OpenGL is available on this system, so OpenGL is used for rendering.
OpenGL Driver Version: 2.1.2
OS: Microsoft Windows XP Professional Service Pack 3 (build 2600)
CPU: 2x Intel(R) Pentium(R) 4 CPU 3.20GHz, 1.5 GiB RAM

Video adapter info:
Adapter type: Intel(R) 82945G Express Chipset Family
Chip Type: Intel(R) 82945G Express Chipset Family
BIOS String: Intel Video BIOS
Video Memory: 131072 KB

Also, I am using the no-install version of Workbench (hence why it is running out of My Documents).

The server MySQL version is 5.0.88.
[29 Jun 2010 21:43] Miguel Solorzano
The remote server it is on slower connection?. Thanks in advance.
[29 Jun 2010 22:49] Steve Small
No, the server is on the local network. Sorry, I guess I should have specified networked server rather than remote server.
Thanks all for your responses.
[6 Jul 2010 15:05] Miguel Solorzano
Could you please try version 5.2.25. Thanks in advance.
[6 Jul 2010 21:59] Steve Small
Hey,

I updated to the new version of Workbench (still using the no-install version), but this has not fixed the problem. The same symptoms still persist.

Thanks,
Steve
[8 Jul 2010 9:45] Sveta Smirnova
Thank you for the feedback.

What happens if you wait for some time after importing data? Will WB show diagram again?

Please also run task manager in time when problem occurs and send us screenshot of what task manager shows. I am interested in content of "Processes" and "Performance" tabs
[20 Jul 2010 15:43] Steve Small
Hey,

I know it has been awhile since my last update here, but I eventually realized that the set of tables I was trying to model were the only set of tables in the database without any foreign keys or anything set. So theoretically, there wasn't anything to 'map.' However, I do believe that the program should handle these situations in a better manner. Maybe still show the boxed representing tables still, without links between them. 

Thanks for all of the help,
Steve
[10 Aug 2010 10:32] Susanne Ebrecht
Many thanks for writing a bug report.

Verified as described by using Workbench 5.2.26.

Just try to create database from just a few tables of a 3NF database.
[11 Aug 2010 10:54] Susanne Ebrecht
Sorry, seems I mixed up bug reports yesterday.

Your problem is not a Workbench problem at all.

Its related to your machine/system/memory.

Remove all from Workbench including configuring.

Check your disk and your hardware.

Re-install a fresh downloaded Workbench.

If you have less then 3 GB RAM just make sure that nothing else on the machine will use RAM.
[4 Mar 2011 10:18] Alexey Terentiev
I have exactly same problem.

MySQL Workbench CE for Windows version 5.2.31
Configuration Directory: C:\Documents and Settings\terentiev\Application Data\MySQL\Workbench
Data Directory: C:\Program Files\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
Rendering Mode: OpenGL is available on this system, so OpenGL is used for rendering.
OpenGL Driver Version: 2.1.8543 Release
OS: Microsoft Windows XP Professional Service Pack 3 (build 2600)
CPU: 2x AMD Athlon(tm) 64 X2 Dual Core Processor 4800+, 3.1 GiB RAM
Active video adapter: ATI Radeon X1200 Series
Installed video RAM: 700 MB
Current video mode: 1280 x 1024 x 4294967296 colors
Used bit depth: 32
Driver version: 6.14.10.6925
Installed display drivers: ati2dvag.dll
Current user language: Russian

I cant even create a new diagram without using any existing databases.