Bug #54813 Installer Fails.
Submitted: 25 Jun 2010 16:45 Modified: 20 Jul 2010 19:58
Reporter: Michael Garcia Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / NET Severity:S1 (Critical)
Version:6.3.2 OS:Microsoft Windows (Windows 7 x64)
Assigned to: CPU Architecture:Any
Tags: install

[25 Jun 2010 16:45] Michael Garcia
Description:
When trying to install the 6.3.2 beta it will progress as normal through the install until the end, then it will roll back and say install failed. 6.2.3 Installs Fine.

Log attached to private comments.

How to repeat:
Run mysql.data.msi and install using typical settings.
[25 Jun 2010 17:19] MySQL Verification Team
Couldn't repeat on Vista Home Premium X86_64.
[25 Jun 2010 18:08] Michael Garcia
Couple details about my environment

Win7 x64 Enterprise
both VS 2008 and VS2020 installed
If you need any other details or logs I can provide them.
[25 Jun 2010 18:10] Michael Garcia
I meant to say VS2008 and VS2010
[28 Jun 2010 8:05] Tonci Grgin
Hi MIC.

Please do not paste such long text ever again to report, makes it unreadable. Now, from what I gather, you have environment like this:
 o W7 x64
 o Both .NET FW 2.0 and 4.0
 o You are running as administrator
 o You are installing from disk D to disk E (MSI (s) (DC:30) [11:30:10:055]: Dir (target): Key: TARGETDIR	, Object: E:\)
 o Both VS2008 and VS2010 present.

Now, I'd like to know:
 o What happens if you install "Complete" and without changing the default directory/disk?
 o Are both VS versions PRO? Only Pro versions support plugins.
 o Is there a previous install of c/NET lingering around on the box?

Your environment will be hard to match as we, as a rule, do not mix 2008 and 2010 on our boxes...

Finally, the line causing the problem seems to be:
MSI (s) (DC:30) [11:30:12:065]: Executing op:
CustomActionSchedule(Action=ManagedDataInstall,ActionType=3073,Source=BinaryData,Target=CAQuietExec,CustomActionData="C:\Windows\\Microsoft.NET\Framework\v2.0.50727\installUtil.exe"
/LogToConsole=false /LogFile=  "C:\Program Files (x86)\MySQL\MySQL Connector Net
6.3.2\Assemblies\v2.0\MySql.Data.dll")
[29 Jun 2010 16:35] Michael Garcia
I have added a new log of what happens when I do a complete install

Both VS are pro editions. I keep VS2008 around for some legacay apps (VS2010 will not talk to SQL server 2000)

I did have 6.2.3 installed but I uninstalled it before the last try. I reinstalled it (works fine in vs2008). I then uninstalled it to try again with the complete install.

And I am sorry about posting the log in full form, if possible please delete that post.
[29 Jun 2010 16:42] Michael Garcia
One thing I noticed, on the errored line you pointed out there are two backslashes after C:\Windows and one everywhere else. Could it be a issue with my global path variables?
[20 Jul 2010 19:58] Reggie Burnett
I believe this is a duplicate of 53975 which has been fixed.  If it continues after release of 6.3.3 then please repost