Bug #54800 Filling varbinary field in modeling not possible on linux
Submitted: 25 Jun 2010 9:25 Modified: 25 Jun 2010 12:25
Reporter: Susanne Ebrecht Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S3 (Non-critical)
Version:5.2.24 OS:Linux
Assigned to: CPU Architecture:Any
Triage: Needs Triage: D3 (Medium)

[25 Jun 2010 9:25] Susanne Ebrecht
Description:
DROP DATABASE IF EXISTS varbintest;

CREATE DATABASE varbintest;
USE varbintest;

CREATE TABLE t(
i INTEGER,
vc VARCHAR(100),
vb VARBINARY(100)
)ENGINE=MYISAM CHARSET=utf8 

Open Workbench ...
create EER model from existing db
choose varbintest database

double click table t
choose INSERT tab

try to insert varbinary data

Workbench won't let you do it.

How to repeat:
See above
[25 Jun 2010 12:25] Alfredo Kojima
Works for me, varbinary and blob fields must have its contents set through the blob editor or loaded from a file, same for all platforms.