Bug #54725 Workbench doesn't autodetect my.ini properly if %programfiles% not on C:
Submitted: 23 Jun 2010 9:13 Modified: 29 Oct 2010 17:06
Reporter: Tobias Asplund Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.15, 5.2.28 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[23 Jun 2010 9:13] Tobias Asplund
Description:
It seems that when adding a new instance, the my.ini file isn't detected if %programfiles% is on D:\

I click New Server Instance -> localhost -> windows 5.1 installer (x86)

I then get an error that %ProgramFiles%\MySQL\MySQL Server 5.1\my.ini doesn't exist.

However, if I type that path in manually it works - so it seems something

D:\WINNT\system32>echo %ProgramFiles%\mysql\mysql server 5.1\my.ini
D:\Program Files\mysql\mysql server 5.1\my.ini

D:\WINNT\system32>dir "D:\Program Files\mysql\mysql server 5.1\my.ini"
 Volume in drive D is WINNT
 Volume Serial Number is C404-447B

 Directory of D:\Program Files\mysql\mysql server 5.1

06/23/2010  10:27 AM             8,948 my.ini
               1 File(s)          8,948 bytes
               0 Dir(s)  209,399,709,696 bytes free

If I press "show log" I get the following:

Checking command 'sc query mysql | wba_filter(RUNNING)'

Server detected as running

Check if %ProgramFiles%\MySQL\MySQL Server 5.1\my.ini exists locally

ERROR: Test Error: File %ProgramFiles%\MySQL\MySQL Server 5.1\my.ini doesn't exist

Operation failed: File %ProgramFiles%\MySQL\MySQL Server 5.1\my.ini doesn't exist

How to repeat:
download the 5.1 installer package, just pick defaults on everything.
download the workbench package, install with defaults.

Then follow the steps above.
[23 Jun 2010 9:28] Valeriy Kravchuk
Please, check if the same problem happens with a newer version of Workbench, 5.2.24.
[23 Jul 2010 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[3 Oct 2010 0:12] Michael Uray
I have the the Workbench Version 5.2.28 on a Windows 7 System.
The problem also happens on it.

On the server side are running:
- Windows XP SP3 (German Edition)
- MySQL Server 5.1.43-community
- FreeSSHd

The SSH User has Administrator privilegs an has read/write access to the my.ini file.

First i tried to add a connection without the SSH remote management, but i got following message, wenn i try to connect:

Error Starting Workbench Administrator
Exception: Unsupported administration target type:
('windows', 'unknown', 'local')
[3 Oct 2010 0:58] Michael Uray
I have found now the solution for the problem on my machines.

I changed the home path for the SFTP Server to root of the drive where the my.ini is located.

In the "FreeSSHDService.ini" 
[SFTP]
SFTPHomePath=$HOME
to
SFTPHomePath=C:\

When this entry is set to "$HOME", the user can just access his home directory, but not direct the system root.

The second thing which was wrong, was the path to the my.ini file in MySQL Workbench.
I have changed it from
C:\Programme\mysql\MySQL Server 5.1\my.ini
to
/Programme/mysql/MySQL Server 5.1/my.ini
[29 Oct 2010 17:47] Michael Uray
I have tested it now on a Windows XP System with Version 5.2.29 CE against the same server and the problem still exists.

After the "Add New Server Instance Profile" action, i got the following message, because Workbench try to access "%ProgramFiles%\MySQL\MySQL Server 5.1\my.ini" instead "/Programme/mysql/MySQL Server 5.1/my.ini".

---
Check if %ProgramFiles%\MySQL\MySQL Server 5.1\my.ini exists in remote host

Operation failed: File %ProgramFiles%\MySQL\MySQL Server 5.1\my.ini doesn't exist
---

I think the problem is, that the SFTP server can't find %ProgramFiles% (== "C:\Programme" on my system), because the ftp server doesn't know drive letters.

After a manual change to "/Programme/mysql/MySQL Server 5.1/my.ini" it seems to be ok, but i can't verify the functionality at the moment, because i get the following error:
http://bugs.mysql.com/bug.php?id=57695