Bug #54577 cpy paste in editor not working as expected under Linux
Submitted: 17 Jun 2010 8:56 Modified: 18 Jun 2010 13:21
Reporter: Susanne Ebrecht Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S5 (Performance)
Version:5.2.24 OS:Linux
Assigned to:
Triage: Needs Triage: D3 (Medium)

[17 Jun 2010 8:56] Susanne Ebrecht
Description:
1. click to edit SQL script
2. choose a connection
3. Open an existing script from your system
4. In editor press left mouse button and mark some lines of code
5. Release mouse button and scroll to the end of the script or too whatever empty line
6. Make sure that the prompt is in that line
6. Press middle mouse button ...

Nothing will happen :(

Expected: the marked text should get copied here

The Workaround is to use expected Windows cpy-paste-behaviour.

This is really annoying. On Linux Workbench editor should behave on topic cpy-paste like with which Linux users are familiar. 

How to repeat:
See above
[18 Jun 2010 13:06] Alfredo Kojima
I can't repeat.

I did the steps described and clicking middle button (the scrollwheel in my case) pasted the selected text.
[18 Jun 2010 13:21] Alfredo Kojima
Found the problem, you are unselecting the text before pasting. You have
to leave the text selected when clicking the middle button, otherwise it won't work. 
It's the same behaviour as in gedit and other Linux apps.

I'm marking this as Not a Bug.