Bug #5456 If one row contains a null value, all subsequent rows have the column as null
Submitted: 7 Sep 2004 19:57 Modified: 7 Sep 2004 21:59
Reporter: Nick Randell Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / NET Severity:S2 (Serious)
Version:Beta 1.0.0 OS:Microsoft Windows (XP)
Assigned to: Assigned Account CPU Architecture:Any

[7 Sep 2004 19:57] Nick Randell
Description:
When reading from the database, if one column in a row is null, all subsequent rows have the same column set to null

How to repeat:
Read in any data with some rows having null values and subsequent rows not having nulls. After the row with a null column is read in, all subsequent rows have null for that column.

Suggested fix:
In Field.cs line add 'colValue.IsNull = false' at line 263 after doing the null value check
[7 Sep 2004 21:59] Reggie Burnett
This is a duplicate of bug #5388