Bug #54539 Copy/Paste does not work with Find/Replace Dialog
Submitted: 16 Jun 2010 1:39 Modified: 16 Jun 2010 11:12
Reporter: Corey Martini Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.22 OSS OS:Microsoft Windows
Assigned to: Mike Lischke CPU Architecture:Any
Tags: copy, find, paste, REPLACE

[16 Jun 2010 1:39] Corey Martini
Description:
When using the Find and Find/Replace dialogs text that is pasted to the Find or Replace text boxes is instead pasted to the last cursor location rather than the text box.  Also the copy does not copy from selected text in these text boxes.  The functionality to have the dialog as modeless is useful so that text can be copied from the current document, however the copy and paste does not behave as expected once the Find or Replace text boxes are selected/activated.

How to repeat:
Open MySQL Workbench SQL Editor
Type some text
Select and copy the text
Open Find or Find/Replace Dialogs.
Attempt to paste the text into the Find or Replace Text boxes.
Attempt it a few more times for good measure.

Suggested fix:
Modify the dialog so that when the text boxes are selected/active then copy and paste is applied to the text in these text boxes rather than the editor window.

If text in the editor window is selected/active then the current functionality should remain.
[16 Jun 2010 3:26] MySQL Verification Team
Thank you for the bug report.
[16 Jun 2010 8:09] Mike Lischke
Is this really on any OS or just Windows? If this is only on Windows then this report is a duplicate of Bug #53735.
[16 Jun 2010 11:10] Corey Martini
Yep, it is Windows.  It looks the same as the bug mentioned.  Missed that one when I searched for similar issues.
[16 Jun 2010 11:12] Corey Martini
Duplicate of Bug #53735.
[16 Jun 2010 11:35] Mike Lischke
Thanks for clarifying this. Set OS to Windows.