Bug #54523 Clicking '+' next to table name in ObjectBrowser fails to open structure view
Submitted: 15 Jun 2010 16:09 Modified: 28 Nov 2010 23:57
Reporter: Gisbert Selke (Basic Quality Contributor) Email Updates:
Status: No Feedback Impact on me:
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.22 OSS rc, 5.2.24, 5.2.25, 5.2.26, 5.2.27 OS:Windows (XP)
Assigned to: CPU Architecture:Any
Tags: qc

[15 Jun 2010 16:09] Gisbert Selke
Clicking on the plus sign next to a table in the Object Browser side bar of the SQL Editor pane (under <database> - Tables - <list of tables>) should open s structural view showing the attributes of the table. Sometimes it just doesn't -- the plus sign vanishes, but nothing opens. 
It is not possible to retry directly since there is no longer any plus sign on which to click. However, after "Refresh All" and navigating to the table again it will, in general, work as it should.
Trying the same on a table above or below will, in general, work quite OK.
The problem occurs occasionally (and has done for several previous versions now), but is not reproducible.

How to repeat:
See above:
Open SQL Editor pane. Go to Object Browser. Choose some schema. Open by clicking '+'. Open Tables view by clicking '+'. See list of tables, pick one, click on '+' next to it.
(As mentioned, the bug is not strictly reproducible. You may have to try several.)
[15 Jun 2010 17:59] MySQL Verification Team
Thank you for the bug report. Could you please provide a screen-shot of the issue reported?. Thanks in advance.
[16 Jun 2010 13:51] Gisbert Selke
Screenshot of problem as described

Attachment: 54523_1.png (image/png, text), 18.42 KiB.

[16 Jun 2010 13:55] Gisbert Selke
The screenshot shows the effect. Before, there had been a '+' box next to table check_id on the right hand side. After clicking on the plus sign, it vanished, and the attributes of the table are not revealed. 
(Btw, on this occasion, even "refresh all" did not help, the problem just happened again.)
To be sure, there is no problem with the underlying table on the server. The table is just fine. Only the display isn't.
[17 Jun 2010 6:10] Susanne Ebrecht
Which sql-mode are you using on server?

[17 Jun 2010 10:09] Gisbert Selke
SQL mode is

I don't, however, think it is something on the server. As described, the problem is intermittent: One table might work ok, the next one not; a minute later, it may be different.
[17 Jun 2010 10:31] Valeriy Kravchuk
What exact version of MySQL server, x.y.z, do you work with? When you'll see such a table, try to execute in SQL Editor:

show create table db.tbl;

and check if you'll get error message. I was able to get this problem once with 5.0.89 and for the problematic table SHOW above gave me:

"Error Code: 1168
Unable to open underlying table which is differently defined or of non-MyISAM type or doesn't exist)"

This was a MERGE table with one of tables it was based on already re-defined to something different. I wonder is it the case for you as well.
[17 Jun 2010 10:47] Gisbert Selke
I get the problem at least on 5.1.39-community, 5.1.36-community and 5.0.90-enterprise-gpl-nt.
To repeat, this is an intermittent problem. On one and the same table in one and the same schema in one and the same database instance on one and the same server it may occur now, or it may not. If and when it occurs, doing "refresh all" in Workbench may (or may not) cure the problem (see my original posting).
I get the problem at least on 5.1.39-community, 5.1.36-community and 5.0.90-enterprise-gpl-nt.
It has nothing to do with MERGE table. Specifically, the table for which I posted the screenshot is *not* a MERGE table but rather plain MyISAM.
[17 Jun 2010 11:02] Valeriy Kravchuk
OK. I guessed based on local experience, and I was wrong. 

Please, send the results from Help > System Info menu item.
[17 Jun 2010 11:36] Gisbert Selke
Thank you, Valeriy!
Output from Help -> System Info:

get_server_version: parsed (5, 1, 39)
x32 on x32
get_server_version: parsed (5, 1, 36)
get_server_version: parsed (5, 0, 90)
MySQL Workbench OSS for Windows version 5.2.22
Cairo Version: 1.8.8
Rendering Mode: OpenGL is available on this system, so OpenGL is used for rendering.
OpenGL Driver Version: 1.5.0 - Build
OS: Microsoft Windows XP Professional Service Pack 3 (build 2600)
CPU: 2x Intel(R) Core(TM)2 Duo CPU     L7100  @ 1.20GHz, 2.0 GiB RAM
Video adapter info:
Adapter type: Mobile Intel(R) 965 Express Chipset Family
Chip Type: Mobile Intel(R) 965 Express Chipset Family
BIOS String: Intel Video BIOS
Video Memory: 393216 KB
[17 Jun 2010 11:46] Gisbert Selke
Just now I had another case of the phenomenon at issue. This time, it *did* concern a MERGE table (in other cases, it definitely also hit non-MERGE tables). I then did "refresh all" (as per WB context menu), and tried again -- voila, works again as it should! (Otherwise, no server interaction involved in the meantime.)
Just for the record, here's the SHOW CREATE TABLE (names slightly obfuscated):
'CREATE TABLE `s_all` (
  `j` year(4) NOT NULL,
  `z` tinyint(2) unsigned NOT NULL,
  `r` char(2) COLLATE latin1_german1_ci NOT NULL,
  `l` mediumint(5) unsigned NOT NULL,
  `s` char(1) CHARACTER SET latin1 COLLATE latin1_bin NOT NULL,
  `v` int(10) unsigned NOT NULL,
  `b` double(15,2) NOT NULL,
  `n` double(15,2) NOT NULL,
  `zu` double(15,2) NOT NULL,
  `d` double(15,3) NOT NULL,
  UNIQUE KEY `IDX_s_all` (`j`,`z`,`r`,`l`,`s`)
[22 Jun 2010 8:46] Susanne Ebrecht

there is some server action in the background.

When I tried to reproduce your problem a few days ago I run into a server problems. That is why I asked for SQL mode.

Your problem not seems to be similar to mine ...
anyway, we could need output from last command of general log.

The other alternative is ...
We fixed lots of stuff between 5.2.22 and 5.2.24.

Workbench 5.2.24 RC came out yesterday. I would plead you to try these version first and let us know if problem still exist.
[23 Jun 2010 22:04] Gisbert Selke
Yes, I perfectly believe there is server action in the background; I didn't mean to imply there isn't. What I meant is that the problem never occurred (to me, anyway) when trying "describe <table>" or "show create table ..." (using any database access tool), but only within Workbench -- that's why I assume it's not caused by the server. (I may be wrong here.)

In any case, I installed 5.2.24 CE RC (thanks for the pointer!). The problem still persists. I will attach a new screenshot of the Object Browser.

Interestingly, the lower pane of the Browser window does show the description of the table in question. So, the information is actually available to Workbench, but it is not displayed properly in the upper pane of the Object Browser.
[23 Jun 2010 22:05] Gisbert Selke
Screenshot of problem as described, in Workbench 5.2.24 CE RC

Attachment: 54523-2.png (image/png, text), 20.81 KiB.

[24 Jun 2010 11:52] Susanne Ebrecht
This could be related to bug #54773.
[29 Jun 2010 0:16] MySQL Verification Team
Maybe related to hardware or some OS environment factors. I couldn't repeat on Windows Vista Ultimate/Home Premium X86_64 and XP Home Edition SP3 32-bits.
[29 Jun 2010 8:08] Gisbert Selke
As stated, the problem occurs for me under Windows XP SP3 32bits (see my entry of 17 June). To repeat again, it is an intermittent bug. If I knew exactly how to reproduce I would have posted it. In any case, it has been present for several versions of Workbench now, though I cannot say with which version it started (or whether it has been present since the first available version).
I do not see anything vaguely similar for any other of the application I run. If someone can point me to which "hardware or some OS environment factors" I should check I will happily do so.
[29 Jun 2010 10:53] Susanne Ebrecht

as I already pointed out I think that your observations by using Windows are related to bug 54773. The bug describes '+' behaviour under Linux and it is behaving totally wrong.

I would like to wait until the other bug is fixed. I have the hope that then your problem is fixed too.
[29 Jun 2010 12:30] Gisbert Selke
Yes, happily, Susanne.
(I was referring to Miguel's remark that he cannot reproduce it under WinXP. I have no personal experience with Workbench on other systems.)
[2 Jul 2010 15:40] MySQL Verification Team
Could you please try version 5.2.25. Thanks in advance.
[12 Jul 2010 12:12] Gisbert Selke
The problem persists in 5.2.25.
[10 Aug 2010 10:21] Susanne Ebrecht
Set back to verified after I tested with Workbench 5.2.26 and figured out problem still exist.
[12 Aug 2010 9:52] Susanne Ebrecht
Hello Gisbert,

I tested yesterday with our 5.2.26 pre-release.

Today I installed the final Workbench 5.2.26 and figured out that these problem here is fixed for me.

I am not able anymore to repeat this.

I will close this bug report now.

Please try Workbench 5.2.26 (we published it a few days ago).

If you still will have this problem, just feel free to re-open this bug report again.
[7 Sep 2010 15:46] Gisbert Selke
The problem persists in 5.2.27.
[19 Sep 2010 23:10] Alfredo Kojima
Please check whether selecting/hilighting the row before clicking the + makes any difference for this effect. Ie, 1st expand the table by clicking the + and then select the row before clicking the +
[29 Nov 2010 0:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".