Bug #54402 Memory Error when trying to connect to any database
Submitted: 10 Jun 2010 15:06 Modified: 11 Jun 2010 13:22
Reporter: Sebastian Pleschko Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S1 (Critical)
Version:5.2.* OS:Windows (XP SP3)
Assigned to: CPU Architecture:Any

[10 Jun 2010 15:06] Sebastian Pleschko
Description:
I try to connect to a database and get an error message saying there was some kind of memory error.

I'm afraid, the program is only 50% useful like this...

This is the clipboard info:

Exception = System.AccessViolationException
Message = Es wurde versucht, im geschützten Speicher zu lesen oder zu schreiben. Dies ist häufig ein Hinweis darauf, dass anderer Speicher beschädigt ist.
FullText = System.AccessViolationException: Es wurde versucht, im geschützten Speicher zu lesen oder zu schreiben. Dies ist häufig ein Hinweis darauf, dass anderer Speicher beschädigt ist.
   bei std.basic_string<char,std::char_traits<char>,std::allocator<char> >.{ctor}(basic_string<char\,std::char_traits<char>\,std::allocator<char> >* , SByte* )
   bei MySQL.Forms.UtilitiesImpl.load_passwords()
   bei MySQL.Forms.UtilitiesImpl.find_password(basic_string<char\,std::char_traits<char>\,std::allocator<char> >* service, basic_string<char\,std::char_traits<char>\,std::allocator<char> >* account, basic_string<char\,std::char_traits<char>\,std::allocator<char> >* password)
   bei MySQL.MCallback3<bool\,std::basic_string<char\,std::char_traits<char>\,std::allocator<char> > const \&\,std::basic_string<char\,std::char_traits<char>\,std::allocator<char> > const \&\,std::basic_string<char\,std::char_traits<char>\,std::allocator<char> > \&>.cpp_callback(basic_string<char\,std::char_traits<char>\,std::allocator<char> >* a1, basic_string<char\,std::char_traits<char>\,std::allocator<char> >* a2, basic_string<char\,std::char_traits<char>\,std::allocator<char> >* a3)
   bei MySQL.Forms.DrawBoxImpl.drawbox_mouse_double_click(Object sender, MouseEventArgs e)
   bei System.Windows.Forms.Control.OnMouseDoubleClick(MouseEventArgs e)
   bei System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   bei System.Windows.Forms.Control.WndProc(Message& m)
   bei System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   bei System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   bei System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
Whenever I try to connect to a database this happens.
Was working fine until it stopped to work after changes to the OS (System Updates, domain changed)

Then (I was using 5.2.16) I started to get these errors. Uninstalled, installed 5.2.22 and got the same behavior. Uninstalled again and installed 5.1.16 again. Still the same. 

Installation files come directly from your website.
[10 Jun 2010 15:17] Mike Lischke
It looks like your password vault got corrupted somehow or something with it is wrong. Would it be possible for you to send us this file? You can add it as a private comment so it is no visible to the world. You can find it at: C:\Documents and Settings\<user name>\Application Data\MySQL\Workbench\workbench_user_data.dat. The file will of course kept confident.

You can also try to rename it and see if you can continue to connect then.
[10 Jun 2010 15:24] Sebastian Pleschko
Renaming the file fixed the problem, thanks! I'll post the dat file as well..
[10 Jun 2010 16:06] MySQL Verification Team
Then the issue is resolved?. Thanks in advance.
[11 Jun 2010 13:22] Sebastian Pleschko
yes, from my point of view, absolutely. Was related to the Windows Domain change, which apparently adversly affected several ApplicationData Files. However, falling back to an empty password would probably be a nicer solution than dying with a "courrupted memory" error!

Thanks for your super quick response!