Bug #54353 A normal 6 character string is shown as BLOB
Submitted: 9 Jun 2010 3:18 Modified: 9 Jun 2010 3:57
Reporter: Anil Konsal Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S2 (Serious)
Version:5.2.22 RC2 OS:Microsoft Windows (7)
Assigned to: CPU Architecture:Any

[9 Jun 2010 3:18] Anil Konsal
Description:
When i try to run a query

select SUBSTRING(MD5(rand()) FROM 1 FOR 6)

I am shown the result as BLOB field whereas its a simple 6 character string not a binary object. IN Earlier stable version, the output is correct. 

Also when i want to know the SHA1 equivalent of any word, it shows me the result as BLOB and I cannot export the result.

How to repeat:
run the query

select SUBSTRING(MD5(rand()) FROM 1 FOR 6)

and see the result and try to export it.
[9 Jun 2010 3:57] Valeriy Kravchuk
Looks like a duplicate of bug #53920. Check last comment there.