Bug #54270 rename _config to -config (mysql_config, ndb_config)
Submitted: 6 Jun 2010 22:49
Reporter: Nathan Brink Email Updates:
Status: Open Impact on me:
Category:MySQL Server: C API (client library) Severity:S4 (Feature request)
Version: OS:Any
Assigned to: CPU Architecture:Any

[6 Jun 2010 22:49] Nathan Brink
The de-facto standard for files which provide the sorts of information that mysql_config provides is for the file to be named <libname>-config. The standard uses a dash rather than an underscore.

How to repeat:
Why are all bugs forced into a model of the ``ideal bug'' which I am not reporting?

Suggested fix:
I suggest that to
1. reduce confusion of users new to ndb and developers using libmysqlclient
2. increase autonomy of programs which look for files name *-config
, the *_config files should be renamed to *-config. Of course, it would be helpful and likely necessary that the mysql distribution install a symlink from mysql_config to mysql-config and likewise for ndb-config; this would provide backwards-compatibility.