Bug #54252 Mysql ODBC 5.1 Driver Does not work with Filemaker ODBC
Submitted: 5 Jun 2010 6:08 Modified: 7 Feb 2017 13:47
Reporter: Dave Iltis Email Updates:
Status: Not a Bug Impact on me:
None 
Category:Connector / ODBC Severity:S2 (Serious)
Version:5.1 OS:Mac OS X (10.5.8)
Assigned to: Bogdan Degtyariov CPU Architecture:Any
Tags: driver, filemaker, MySQL, ODBC

[5 Jun 2010 6:08] Dave Iltis
Description:
The mysql ODBC 5.1 driver does not work with Filemaker 10.

There seems to be something broken in the table lookup.

It connects, but returns and error that says 'ODBC Error [MYSQL][ODBC 5.1 Driver][mysqld-5.1.39-log]Table databasename.databasename doesn't exist.'

This occurs when trying to connect to a table in databasename.

How to repeat:
Use external data sources in filemaker 10.

The driver tests ok in ODBC Administrator, but will not function in filemaker.
[7 Jun 2010 6:33] Tonci Grgin
Hi Dave and thanks for your report.

I'd like you to attach an ODBC trace from driver manager for this situation (see documentation on how to do this). I'd also like to know which options you used in your DSN and which kind of DSN is used.

I can not promise we'll be able to do anything as, afaik, we do not have/use FileMaker.
[9 Jun 2010 8:12] Tonci Grgin
Dave, please check on-line manual (http://dev.mysql.com/doc/refman/5.5/en/connector-odbc.html) and see if it has references on ODBC tracing for Mac OS. Alas, as FileMaker is commercial SW I can not find anyone with valid license.
[3 Jul 2010 0:53] Chris Calender
Here is the link on how to obtain an ODBC Trace File:

http://dev.mysql.com/doc/refman/5.1/en/connector-odbc-configuration-trace.html
[9 Jul 2010 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[11 Aug 2010 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[29 May 2013 6:04] Bogdan Degtyariov
I'm closing this bug because I can not continue without feedback from the reporter. If you have new info, please reopen the report.
[29 May 2013 7:50] Bogdan Degtyariov
reopening, we have the FileMaker.
[7 Feb 2017 13:47] Bogdan Degtyariov
Posted by developer:
 
This is not a bug, but incorrect handling of UNICODE data by FileMaker.
Therefore, it is recommended to use the ANSI version of Connector/ODBC 5.3