Bug #54245 Schema mydb appears in forward engineering script for different schema
Submitted: 4 Jun 2010 18:16 Modified: 7 Jun 2010 7:23
Reporter: Michael LaBrot Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S2 (Serious)
Version:5.2.22 OS:Microsoft Windows (XP Pro)
Assigned to: CPU Architecture:Any

[4 Jun 2010 18:16] Michael LaBrot
Description:
When creating a forward engineering script for objects in schema 'legacy', extraneous statements for schema 'mydb' are also produced.

DROP SCHEMA IF EXISTS `mydb` ;
CREATE SCHEMA IF NOT EXISTS `mydb` DEFAULT CHARACTER SET latin1 COLLATE latin1_swedish_ci ;
DROP SCHEMA IF EXISTS `legacy` ;
CREATE SCHEMA IF NOT EXISTS `legacy` DEFAULT CHARACTER SET latin1 ;
USE `mydb` ;
USE `legacy` ;

How to repeat:
1.) Open a model.
2.) Database > Forward Engineer...
3.) Click Next.
4.) Click Next.
5.) Look for the string 'mydb'.
[4 Jun 2010 18:54] Michael LaBrot
Might just be me. My model had a tab for the mydb schema even though there were no objects in it. I deleted the schema from my model and am good to go.
[7 Jun 2010 7:23] Valeriy Kravchuk
So, looks like this problem was not a result of any bug.