Bug #54239 MySQL Crashes on Load Data Script
Submitted: 4 Jun 2010 16:24 Modified: 9 Jun 2010 9:20
Reporter: TJ Barra Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.21, 5.2.22 OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Tags: crashes, LOAD DATA, regression

[4 Jun 2010 16:24] TJ Barra
Description:
MySQL Workbench 5.2.21 crashes when I enter the following script

truncate testing.table1;
load data local infile 'c:/testtable.txt' into table testing.table1
                  fields terminated by '!'
                  lines terminated by '\r\n';

I receive the following error message that says
MySQL Workbench has encountered a problem and needs to reclose.  We are sorry for the inconvenience.

This same script worked in previous versions of MySQL Work Bench (maybe 5.2.19 and before?)...the script works on MySQL Query Browser 1.2.17...but it is rather inconvenient to open up the query browser to run this one script when I use work bench for everything else

How to repeat:
load data local infile 'c:/testtable.txt' into table testing.table1
                  fields terminated by '!'
                  lines terminated by '\r\n';
[4 Jun 2010 16:43] MySQL Verification Team
Thank you for the bug report. Could you please try 5.2.22. Thanks in advance.
[6 Jun 2010 13:08] TJ Barra
Same problem occurs on 5.2.22
[7 Jun 2010 8:59] Valeriy Kravchuk
How large this c:/testtable.txt file is? Please, send also CREATE TABLE statement for the table you are loading data into.
[7 Jun 2010 13:38] TJ Barra
The text file I am importing is 15mb...it contains 82,000 rows

CREATE TABLE  testing.table1 (
  `f1` varchar(6) DEFAULT NULL,
  `f2` varchar(25) DEFAULT NULL,
  `f3` varchar(25) DEFAULT NULL,
  `f4` int(1) DEFAULT NULL,
  `f5` int(2) DEFAULT NULL,
  `f6` varchar(25) DEFAULT NULL,
  `f7` int(2) DEFAULT NULL,
  `f8` int(8) DEFAULT NULL,
  `f9` varchar(25) DEFAULT NULL,
  `f10` varchar(25) DEFAULT NULL,
  `f11` int(8) DEFAULT NULL,
  `f12` varchar(25) DEFAULT NULL,
  `f13` varchar(25) DEFAULT NULL,
  `f14` int(8) DEFAULT NULL,
  `f15` varchar(25) DEFAULT NULL,
  `f16` varchar(25) DEFAULT NULL,
  `f17` int(2) DEFAULT NULL,
  `f18` int(1) DEFAULT NULL,
  `f19` int(1) DEFAULT NULL,
  `f20` int(8) unsigned DEFAULT NULL,
  `f21` varchar(25) DEFAULT NULL,
  `f22` varchar(25) DEFAULT NULL,
  `f23` varchar(15) DEFAULT NULL,
  `f24` int(8) DEFAULT NULL,
  `f25` varchar(25) DEFAULT NULL,
  `f26` varchar(25) DEFAULT NULL,
  `f27` varchar(15) DEFAULT NULL,
  `f28` int(8) DEFAULT NULL,
  `f29` varchar(25) DEFAULT NULL,
  `f30` varchar(25) DEFAULT NULL,
  `f31` varchar(15) DEFAULT NULL,
  `f32` int(2) DEFAULT NULL,
  `f33` int(2) DEFAULT NULL,
  `f34` int(1) DEFAULT NULL,
  `f35` varchar(2) DEFAULT NULL,
  `f36` int(2) DEFAULT NULL,
  `f37` int(2) DEFAULT NULL,
  `f38` varchar(10) DEFAULT NULL,
  `f39` int(3) DEFAULT NULL,
  `f40` varchar(15) DEFAULT NULL,
  `f41` varchar(15) DEFAULT NULL,
  `f42` varchar(15) DEFAULT NULL,
  `f43` varchar(15) DEFAULT NULL,
  `f44` int(3) DEFAULT NULL,
  `f45` int(3) DEFAULT NULL,
  `f46` varchar(25) DEFAULT NULL,
  `f47` int(1) DEFAULT NULL,
  `f48` int(8) DEFAULT NULL,
  `f49` varchar(25) DEFAULT NULL,
  `f50` varchar(25) DEFAULT NULL,
  `f51` varchar(2) DEFAULT NULL,
  `f52` int(8) DEFAULT NULL,
  `f53` varchar(25) DEFAULT NULL,
  `f54` varchar(25) DEFAULT NULL,
  `f55` varchar(2) DEFAULT NULL,
  `f56` varchar(100) DEFAULT NULL,
  KEY `Index_1` (`f1`,`f2`,`f3`,`f4`,`f5`,`f6`,`f7`,`f17`)
) ENGINE=MyISAM DEFAULT CHARSET=latin1$$
[7 Jun 2010 18:39] Aaron Suggitt
I have the same problem on Mac OS 10.6 using Workbench 5.2.22. Load file has 1056 rows and is only 45KB in size.

CREATE TABLE `coding_icdO_3` (
  `id` int(11) NOT NULL,
  `code` varchar(45) NOT NULL,
  `description` varchar(200) NOT NULL,
  PRIMARY KEY (`id`),
  UNIQUE KEY `code_UNIQUE` (`code`)
) ENGINE=InnoDB DEFAULT CHARSET=latin1

LOAD DATA LOCAL INFILE '<Path to file>/ICDO.csv'
INTO TABLE `coding_icdO_3`
FIELDS TERMINATED BY ',' OPTIONALLY ENCLOSED BY '"'
LINES TERMINATED BY '/n'
IGNORE 1 LINES
[9 Jun 2010 9:20] Sveta Smirnova
Thank you for the feedback.

This is duplicate of bug #53661