Bug #54195 binlog_spurious_ddl_errors.test fails, thus disabled
Submitted: 3 Jun 2010 7:46 Modified: 30 Jan 2013 12:33
Reporter: Alexander Nozdrin Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Replication Severity:S3 (Non-critical)
Version:M3 (Celosia), M4 (Dahlia) OS:Any
Assigned to: Assigned Account CPU Architecture:Any
Tags: disabled, pb2, test failure
Triage: Triaged: D3 (Medium)

[3 Jun 2010 7:46] Alexander Nozdrin
Description:
binlog_spurious_ddl_errors.test started to fail in trunk-bugfixing
after the push on '2010-06-02 02:05:28' (patches for BUG#39934,
BUG#50479, BUG#53421, BUG#53437).

The symptoms:
@@ -49,5 +49,7 @@
 #                                 CLEAN UP                                     #
 ################################################################################
 UNINSTALL PLUGIN example;
+Warnings:
+Warning	1620	Plugin is busy and will be uninstalled on shutdown
 SET @@global.binlog_format = @old_binlog_format;
 SET @@session.binlog_format = @old_binlog_format;

The test case is disabled starting from trunk-bugfixing due to this bug.

How to repeat:
I could not reproduce the failure locally (Linux x86_64)
with a single run. Probably it's reproducible under
the high load.

PB: http://tinyurl.com/3534r95
[11 Jun 2010 19:50] Sveta Smirnova
Thank you for the report.

Verified using PB logs. Not repeatable in my environment.
[16 Jun 2010 0:40] Omer Barnir
triage: setting to SR55TEST (assumes issue of test case running in parallel testing env)
[28 Jun 2010 15:03] Sven Sandberg
There are in fact two different error messages. The pb link refers to six mtr logs. Three of them contain the error above (warning on UNINSTALL PLUGIN). The three other contain this error:

binlog.binlog_spurious_ddl_errors [ fail ]
        Test ended at 2010-06-04 16:03:10

CURRENT_TEST: binlog.binlog_spurious_ddl_errors
mysqltest: At line 29: query 'INSTALL PLUGIN example SONAME 'ha_example.so'' failed: 1126: Can't open shared library '/export/home3/pb2/test/sb_4-1895093-1275656150.98/mysql-5.5.5-m3-solaris10-i386-test/lib/plugin/ha_example.so' (errno: 2 ld.so.1: mysqld: fatal: relocation error: file /export/home3/pb2/test/sb_4-1895093-1275656150.98/mysql-5.5.5-m3-solaris10-i386-t)

The result from queries just before the failure was:
SET @old_binlog_format= @@global.binlog_format;

 - saving '/export/home3/pb2/test/sb_4-1895093-1275656150.98/mysql-5.5.5-m3-solaris10-i386-test/mysql-test/var-ps_row/log/binlog.binlog_spurious_ddl_errors/' to '/export/home3/pb2/test/sb_4-1895093-1275656150.98/mysql-5.5.5-m3-solaris10-i386-test/mysql-test/var-ps_row/log/binlog.binlog_spurious_ddl_errors/'

Retrying test, attempt(2/3)...

When it failed with the first error, there was only one failure in the log. When it failed with the latter error, there were always three errors in the log. Both errors seem to happen on several different platforms.

This error is the first test that runs.

Not sure if this can be because of concurrently running tests. Since concurrently running tests execute on different servers, I don't see how there can be any interaction. OTOH, the tests main.plugin and main.plugin_not_embedded execute very short after this test. When the second type of failure happens in binlog.binlog_spurious_ddl_errors, then main.plugin and main.plugin_not_embedded also fail with a similar error message.
[30 Jan 2013 12:33] Jon Stephens
Fixed in 5.5+, pushed to 5.5.31, 5.6.11, 5.7.1. No user-facing changes to document, so closed without further action.