Bug #54127 mysqld segfaults when built using --with-max-indexes=128
Submitted: 1 Jun 2010 7:29 Modified: 12 Mar 2013 16:17
Reporter: Norbert Tretkowski Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Compiling Severity:S2 (Serious)
Version:5.1.45, 5.1.48, 5.1.65, 5.5.15, 5.5.27 OS:Linux (Debian)
Assigned to: CPU Architecture:Any
Tags: Contribution
Triage: Triaged: D1 (Critical)

[1 Jun 2010 7:29] Norbert Tretkowski
Description:
The segfault described in Bug #36751 still (or again) happens with 5.1.45.

How to repeat:
Build MySQL using --with-max-indexes=128 and try to start mysqld.
[1 Jun 2010 8:28] Sveta Smirnova
Thank you for the report.

Verified as described.
[1 Jun 2010 20:53] Omer Barnir
triage: setting SR51MRU (as #36751) was not fixed properly
[8 Sep 2010 15:34] Sergey Shvets
Is there any update on this bug? We also having it on 5.1.48 from offical website.
[30 Oct 2010 11:21] Alex Berdennikov
have the same problem, mysql-5.1.51

./configure --prefix=/usr/local/mysql --enable-assembler --with-charset=utf8 --with-collation=utf8_general_ci --with-mysqld-user=mysql --with-max-indexes=128 --with-ssl=/usr/lib --with-plugins=all 

Linux Debian-50-lenny-64-minimal 2.6.26-2-amd64 #1 SMP Thu Sep 16 15:56:38 UTC 2010 x86_64 GNU/Linux
[18 May 2011 18:25] Alexey Kopytov
Proposed fix for this bug (submitting under the BSD license)

Attachment: bug54127.patch (text/x-patch), 1.34 KiB.

[8 Aug 2011 14:11] Norbert Tretkowski
This affects MySQL 5.5.15 as well, mysqld segfaults with MAX_INDEXES set to 128 in config.h.cmake.
[28 Aug 2012 14:09] Valeriy Kravchuk
Bug #66560 was marked as a duplicate of this one.
[12 Mar 2013 16:17] Paul Dubois
Noted in 5.7.1 changelog.

CMake now has a -DMAX_INDEXES=N option to specify the maximum number
of indexes per table. The default is 64. The maximum is 255.
[15 Mar 2013 14:28] Paul Dubois
Revised changelog entry:

The server could exit if the maximum number of indexes per table was
set to a value larger than 64.

In the course of fixing this problem, a -DMAX_INDEXES=N option was
added to CMake to permit specifying the maximum number of indexes per
table. The default is 64. The maximum is 255.
[16 Mar 2013 15:16] Paul Dubois
Revised changelog entry:

The server could exit if built to permit a maximum number of indexes
per table larger than 64.

In the course of fixing this problem, a -DMAX_INDEXES=N CMake option
was added to permit building the server to support a larger maximum
number of indexes per table. The default is 64. The maximum is 255.
Values smaller than 64 are ignored and the default of 64 is used.