Bug #54125 year(4) datatype not taking values before 19th century.
Submitted: 1 Jun 2010 6:15 Modified: 1 Jun 2010 12:08
Reporter: praneeth kumar Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Data Types Severity:S5 (Performance)
Version:5.5 OS:Any
Assigned to: CPU Architecture:Any
Tags: year, year(4)

[1 Jun 2010 6:15] praneeth kumar
Description:
In my table i want to store values before 19th century, i am using  year(4) datatype. Every time i am trying to insert it is throwing an exception. Is there any solution to this?

How to repeat:
In my table i want to store values before 19th century, i am using  year(4) datatype. Every time i am trying to insert it is throwing an exception. Is there any solution to this?
[1 Jun 2010 12:08] Miguel Solorzano
Thank you for taking the time to write to us, but this is not a bug. Please double-check the documentation available at http://dev.mysql.com/doc/ and the instructions on
how to report a bug at http://bugs.mysql.com/how-to-report.php

Additional Info:

http://dev.mysql.com/doc/refman/5.5/en/year.html

"For four-digit format, MySQL displays YEAR values in YYYY format, with a range of 1901 to 2155, or 0000. For two-digit format, MySQL displays only the last two (least significant) digits; for example, 70 (1970 or 2070) or 69  (2069)."