Bug #54038 DATE_FORMAT displayed as 'BLOB'
Submitted: 27 May 2010 18:24 Modified: 28 May 2010 3:30
Reporter: John McNair Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.21 RC OS:Microsoft Windows (7)
Assigned to: CPU Architecture:Any

[27 May 2010 18:24] John McNair
Description:
When I issue this query: 

select date_format(some_date,'%m/%d/%y') from some_table 

The Results grid displays 'BLOB' for all rows. I can use the 'Open Value in Viewer' context menu to display a single column's value as text, but I want to see the values for DATE_FORMAT, CONCAT, etc., functions displayed as string data in the Results grid. Also, if I try to export these results, the CSV file contains "..." for all rows. 

How can I display string data in the grid instead of the word 'BLOB'?

How to repeat:
Issue any query that uses the DATE_FORMAT or CONCAT functions.
[28 May 2010 3:30] Valeriy Kravchuk
This is a duplicate of Bug #53920. See bug #Bug #54032 for possible workaround.