Bug #5402 AMD 64 RPM requires perl DBI
Submitted: 4 Sep 2004 1:11 Modified: 9 Sep 2004 20:08
Reporter: Donny Simonton Email Updates:
Status: Won't fix Impact on me:
Category:MySQL Server: Packaging Severity:S2 (Serious)
Version:4.1.4 OS:Linux (Linux)
Assigned to: CPU Architecture:Any

[4 Sep 2004 1:11] Donny Simonton
We just got a new server in today, and tried to install 4.1.4 via RPM and this is what we get.

[root@parking-master src]# rpm -i MySQL-client-4.1.4-0.glibc23.x86_64.rpm 
warning: MySQL-client-4.1.4-0.glibc23.x86_64.rpm: V3 DSA signature: NOKEY, key ID 5072e1f5
error: Failed dependencies:
        perl(DBI) is needed by MySQL-client-4.1.4-0.glibc23
[root@parking-master src]# rpm -i MySQL-server-4.1.4-0.glibc23.x86_64.rpm 
warning: MySQL-server-4.1.4-0.glibc23.x86_64.rpm: V3 DSA signature: NOKEY, key ID 5072e1f5
error: Failed dependencies:
        perl(DBI) is needed by MySQL-server-4.1.4-0.glibc23

So I went and installed DBI via CPAN and DBD::mysql and tried to reinstall it again, and still the same problem.

Any ideas?


How to repeat:
Install the 64 bit RPM.

Suggested fix:
Either have a work around for getting the depencies working, or remove the whole perl(DBI) problem all together.  Since mysql shouldn't require perl DBI.
[4 Sep 2004 1:12] Donny Simonton
One more thing, devel does install correctly without any problems.
[8 Sep 2004 21:19] Alexander Keremidarski
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.mysql.com/documentation/ and the instructions on
how to report a bug at http://bugs.mysql.com/how-to-report.php

Additional info:

RPM only seeks for dependaincies in it's database. 

Installing Perl modules without without is call for trouble.

It's not MySQL packagers fault that you decided to not use:

rpm -Uvh perl-DBD-MySQL*.rpm
[8 Sep 2004 21:36] Donny Simonton
Installing the 32 bit version doesn't require me to install Perl DBD::mysql.  I know I have about 10 machines running 32 bit linux and I only use RPM's to install everything on them.  Only the 64 bit version of the RPM has a dependency issue with perl.  

I was setuping 2 brand new boxes, one 64 bit one 32 bit.  Downloaded both versions and installed them on the machines.  Both running same OS one 32 bit one 64 bit version of fedora core 2.  Both I installed with rpm -i the 32 bit version installed fine the 64 bit did not.

I could have just added --nodeps, but that's not a perfect solution.  mysql 64 bit like the 32 bit should not require that perl dbd::mysql be installed.  That's all I am saying.

I ended up installing from source anyway because Peter Zaitsev said that the RPM's are built against SUSE and he said any red hat based system has problems with the 64 bit RPMs that mysql builds.
[9 Sep 2004 20:08] Lenz Grimmer
The 4.1.4 IA64 and AMD64 RPM packages were built on Red Hat AS 3 - the version of RPM included in this OS has added many additional dependency checks, especially for all kinds of Perl modules. Chances are high that these required modules are already installed on your system, but under a different name. 

So it's pretty safe to use "--nodeps" in this case - DBI-perl is only required for certain supplementary scripts that are part of the package.

I will resolve this a "not a bug" - there is not much we can do about this (it's up to the Linux distributors to finally unify these package names)
[13 Oct 2005 10:48] Simon Hobbs
Thankyou Lenz for a decent explanation. It helped me a lot.