Bug #5383 utf-8 encoding does NOT work on windows
Submitted: 3 Sep 2004 9:15 Modified: 6 Sep 2004 13:49
Reporter: akamu akamai Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S1 (Critical)
Version:4.1.4-gamma OS:Microsoft Windows (win32)
Assigned to: CPU Architecture:Any

[3 Sep 2004 9:15] akamu akamai
Description:
as mentioned in #312 utf-8 does not work properly still
I receive this error in my apache error.log
File 'c:\mysql\share\charsets\?.conf' not found (Errcode: 22)
Character set '#33' is not a compiled character set and is not specified in the 'c:\mysql\share\charsets\Index' file

How to repeat:
install it

Suggested fix:
missing files?
[3 Sep 2004 9:17] akamu akamai
mention in http://bugs.mysql.com/bug.php?id=312
is not resolved as of 4.1.4-gamma
[6 Sep 2004 13:49] Victoria Reznichenko
Hi,

Thank you for the report, but this is not a bug. This error is generated by the client, not by the server.
Check that path to charsets dir is set correctly and that your client is compiled with support of utf8 character set.
[16 Feb 2005 14:10] Tammy Bogart
Hi, I have the same issue. I believe it is a bug. I did install with UTF8 support but that didn't fix it.  I don't have any missing files that I am aware of. If a certain file/s would fix this issue would you please post a link to that file so I can download it.
Thanks
[8 Mar 2005 20:58] E Nelson
Is there any way just to hide this error?? I don't really care what is wrong as long as its not showing up on my website.
[15 Mar 2005 3:22] Shawn Hyde
this is a bug, I can login to a 4.0 database with the same code and not get this error. when I login to the 4.1 database I get:

File 'c:\mysql\share\charsets\?.conf' not found (Errcode: 22)
Character set '#33' is not a compiled character set and is not specified in the 'c:\mysql\share\charsets\Index' file
[14 May 2005 1:18] Glen D
I agree.  When I run my scripts locally (on Windows XP, with Apache), I have no problems whatsoever.  When I upload it to my host (brinkster.com), I get the error message.  And the typical error suppression doesn't work.  Any progress on the solution?
[4 Aug 2005 22:26] Amin Taheri
I too just ran into the same situation.  Did anyone else get this resovled?  if so - how?