Bug #53788 It is not possible to start server via Workbench
Submitted: 19 May 2010 8:26 Modified: 22 Jun 2010 12:01
Reporter: Susanne Ebrecht Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S1 (Critical)
Version:5.2.24 OS:Other (Server Unix/Linux, WB doesn't matter)
Assigned to: Assigned Account CPU Architecture:Any
Triage: Needs Triage: D2 (Serious)

[19 May 2010 8:26] Susanne Ebrecht
Description:
1. Install two MySQL instances on a Linux/Unix system.
E.g. MySQL 5.0 and MySQL 5.1 or 5.1.46 and 5.1.47 or whatever.

Configure my.cnf for both, so that both running on different ports.

Start both.

Both processes are named mysqld

2. Open Workbench
New Server Instance

Do correct configuration for first instance
Do correct configuration for second instance

Double click one of the instances

Stop server

Server will stop.

Watching stdout from where server was started will also show that server correct shut down.

But the button won't change from stop server to start server.

If you click stop server again it will tell you that server already is running.

Looking with ps or looking for hostname.pid in data directory will show that server is stopped.

System is not recognising that it because the other server still is running. It is not recognising the right server.

How to repeat:
See above
[20 May 2010 14:25] Alfredo Kojima
Please provide info about your server instance profile.
[21 May 2010 18:19] Alfredo Kojima
By info I mean the ~/.mysql/workbench/server_instances.xml file
[21 Jun 2010 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[22 Jun 2010 12:01] Alfredo Kojima
Actually, duplicate of bug #52688